How fast have you pushed your machine?

I’ve been doing test cuts to see how fast I can successfully cut redwood (which yes, is very soft): I have plans to do a piece a good 20" wide x 30" long x 1" deep, and based on my current speeds & feeds, my time estimates are… large (like, do roughcut for 9 hours day1, pause the machine overnight, finish pass for 12 hours day2). So I thought I’d start doing some test cuts to see how fast I can push the machine and still maintain quality. My findings (so far) are below, but I’d love to hear what others have done.

I’m using a .25" 3 flute upcut ballnose for my rough and finish passes currently. On all tests, DeWalt has done fine set at speed 1: I start it faster concerned that I’m going to fast, but slowly dial it back to 1 in the first minute, and just leave it there.

For rough cut, I’m cutting .125" deep with a .125" stepover (1/2 bit width), leaving .125" of stock behind.
For the finish pass, I’m doing a .025" stepover (10% bit width).

If you’re wondering, the test pieces were modeled in Autodesk Maya, and gcode generated via MeshCAM.

(Edit: Based on below comments, my plunge rate is actually being limited to 20"/min)
My first test was done with the roughcut at 120"/min feed & 60in"/min plunge, and the finish at 150"/min feed & 120"/min plunge. This piece took 50ish minutes, 4.5" x 8", 1" max cut depth (mainly for the votive hole) :


(the crack you see is from the reclaimed wood, not the cut)

The machine didn’t even blink, so I did…

My second test: Roughcut at 150"/min feed & 60"/min pluge, with finish at 180"/min & 120"/min plunge. This piece took 30 minutes, 4" square, 1" max cut depth:

And again, in both cases the machine seemed to have no problem, even with the DeWalt on 1.

I know using a 3-flute is greatly helping the speed, and I plan to push it even more… but I’m wondering if there is an actual maximum for the machine? I’d love to just jump ahead to some known good numbers rather than doing this step by step, as entertaining as it’s been.

Any thoughts appreciated!

2 Likes

@PhilJohnson : No, I did not do any $112ing, one of the reasons I’m posting this, who knows what I’m doing wrong :stuck_out_tongue:
I’ll give that a shot for sure with your # as a start. Thanks for the other info.

1 Like

Thanks, I’m checking that code out now. I have a couple 3d printers and am quite familiar with tweaking their firmware vals, but really haven’t done it too much on the xcarve. Seems like a good time to start :wink:

1 Like

I second what Phil said about acceleration, that is where the actual speed is unless you travel very long distance.
This is the place where small CNCs like X-carve actually benefit from light weight X gantry when machine has to hit the breaks and do 180 in opposite direction, something I tried to do on my very heavy gantry and I snapped both Y axis motor shafts right off.
On wider belts with stock x-carve gantry with 1/4 bit I was never able to go past 180’/min and not see effect of backslash on corner cuts.

Good info: Yah, it’s quite possible that while in software I’m pushing numbers up, the firmware is limiting it all. I should really do the same cut each time for accurate comparison, but that seems boring :stuck_out_tongue:

neat textures. Did you make by hand or download?

Thanks @JeremySimmons : I created them in Autodesk Maya.

Some updated numbers: I changed my firmware speed for Z per the above suggestion, and ran the exact same cut: What took 30 minutes last time was reduced to 22 minutes, not bad! Shows how much my speed was being gated by the firmware. Still had the DeWalt on 1, the only time I noticed any slight chugging was when it hit a knot.

So, I thought I’d do my next set of speed tests: This time roughcut at 180"/min (was 150"/min before), and I started having problems: What’s interesting is, it had no problem roughing the X&Y, still cut just like butter, speed 1… But on the third z-step down in the rough, it jumped to like triple the depth, stated cutting way to deep, and actually pulled the stock up off the table (I only had it held down via friction on the perimeters) as I frantically hit the E-stop. I’d think that if it was trying to descend to fast, it would skip, and not cut deep enough, but this was the opposite effect. Hurumph.

Regardless, I think I’m cutting plenty fast now, thanks for the $112 tip @PhilJohnson

1 Like

Thought I’d follow up with more findings: After I increased the z-stepper speed, the next three (fast) cuts all failed, all based on cutting too deep by the 3rd plunge down during the rough. My theory is that when they hit knots in the boards, it couldn’t cut fast enough during the pluge, and screwed things up. I put the speed back to default, ran the cut again, and it worked fine. But so slow.
My next plan of attack is to speed it back up in firmward, but do my rough cut at default pluge speeds again. Then on the finish push the plunge speed back up, and see if I can get some time savings back.
On this 9x6 test piece, the rough was only 17 minutes, but the finish, with all the ups\downs, took another hour, 13 min :S

@PhilJohnson : Derp: I forget this thing is basically the same as a 3dprinter… and I adjust their pots all the time. Thanks for the tip. Who’d have thought apples and oranges had the same knobs? :wink:

I have the “controller you would have got had you bought this 1 year and 4 months ago” controller. Not the new big one.

1 Like

Yes, the Uno, with the grblshield on top.

How many, if any - have tried adding a fly wheel to their steppers in order to increase maximum rpm before they loose sync? (harmonic dampers)

I think fly wheels could lead to acceleration/ deceleration trouble if the mass is too great on the stepper shaft. If it takes longer to get up to speed and back down again it would also increase the time it takes to run a file.

Acceleration is part of the equation, for sure - and power…
If it is benificial for the Xcarve is another matter entirely :sweat_smile:

Harmonic dampers / fly wheels for steppers isnt unheard of:

Thanks: Based on this handy page:


Using my meter, I checked all my pots, they’re all set to 2.02v, which means I should be applying around 2.5a to all the steppers (which I see are rated at 2.8a), which looks like is max for my current setup. So maybe I’m just going to fast for the current power provided to the machine.

I just did this, but the z motor (269oz) stalls at 1800. I have increased the current pot by 1 click after I installed, so 2.8A, which is the current rating. It works good at 1000 and is way faster, thanks.

FYI, I didn’t change those pots, I was just reading what they were set to, from the factory. I’ve been cutting with this machine… 1yr/4months, haven’t hit any issues so far in regards to that voltage level. I hear your words, and if I was tuning this from scratch (like a 3d printer) I’d definitely start with a lower val, like say, 1.9v, but considering to this point, based on say, 9 hour cuts I’ve done, I’ve had no problems, I think I’ll just leave them be?

Note I did another test: I pushed the firmare back up to 40in/min max (still less than your 70), but limited my rough to 20mm/min, and my finish back at 40mm/min: That had no problems cutting.


6 minute rough, 10 minute finish.

However, I did notice something interesting: When the cut completed, and it raised on z to clear the stock, the z-stepper made a “brrrrrzzzz” sound, and didn’t raise it like it should. Bit didn’t even clear the top of the stock. When I manually jogged it via UGS it had no problem raising/lowering, I but I feel like I’m seeing the weak link in the chain: If when raising Z it skips, that would mean it would cut too deep later, thus causing the problems I’ve been experiencing. I thought it was having a hard time cutting deep fast , but instead, it actually seems like it’s having a hard time raising it fast.

I removed the router from the gantry, and manually started twisting the top z-belt: I can do it by hand, but the higher it goes, the tighter it gets. And, it’s not an even spin, I can tell some parts of the revolution are tighter than others. I slightly loosed the eccentric nuts on the Z v-wheels, but really didn’t notice much of a difference, and any more loosening would concern me. I know it’s waaaaay tighter than what I’d experience on my 3d printer: With my big printer, even with its 12" square aluminum bed & gantry, I can twist the leadscrew with a few fingers on one hand to raise it with not much effort. But I need two hands to do it on the xcarve, even with the router out. Does that sound… wrong? I have plenty of grease, should I grease up that leadscrew? I presume it’s shouldn’t be necessary, but thought I’d throw it out there.

Scratch that, I lost steps in z, so went to 750 and so far so good.

So it’s ok to set the potentiometer above the motors rated amperage? It says 2.8A max on my stepper datasheet, so that’s what I set it to. I just replaced all steppers with 269oz and adusted each pot to 2.8 (3 O’clock position on potentiomenter) and all the steppers are working perfectly, well except the Z after increasing the accel and max speed. I guess I will try to increase amperage. Thanks again!

1 Like

Yes its ok just mind your temperatures if they are very hot to touch you can expect dropping steps.