How to change the GRBL settings on the V-Carve

I just upgraded my X-Carve with the CNC4Newbies Ultimate upgrade. Everything is working great except the accuracy of the machine. The Z axis moves 5 inches when I ask for 1 inch and the X & Y axis move about 3/8 inches when I ask for 1 inch. The Upgrade kit has a list of GRBL settings to change but I don’t know how to do that.

Open Easel, press CTRL+SHIFT+D (Or CMD+SHIFT+D on Mac)
Machine Inspector will open, locate the Console text window (empty)
Type $$ and press Enter, your current GRBL parameters will list below.

To edit any of these values, say for Z axis step/mm value:
$102=NewValue and press Enter
Reboot controller (not always needed but its more consistent) and display the current values ($$) to verify.


1 Like

You should use an accurate rule or caliper to determine the exact distance you are moving for the setting. Then you can use some multiplication or division of that measurement with the measurement you would like it to move. That will determine the new number setting.

For instance ( what you want- 1 inch )/ ( what you get -.375) = 2.666. If your current setting is say 40, then you would multiply that 40 by 2.666 = 106.64. Then you would replace the 40 with 106.64