How to Make Clamp Set?

I’d like to make the clamp set and I see the link includes a PDF drawing showing the dimensions as well as a DXF file, which I can open in Inkscape but it appears to be the same as the PDF. That is, it shows a top view, side view, etc. But what is the file I can just load into Easel and then carve from? (I’ve been successful at carving 2D objects like the walnut and aluminum bottle opening, but haven’t tried doing anything that is 3D, i.e. I don’t see how to tell Easel about the slope/ramp at the end of the clamp so that the router makes a diagonal cut down). (I’m sure there is a better way to explain what I’m asking but I’m still new to CNC. I basically don’t know how to describe slopes in the Z-axis, just to tell it a depth of a particular line.)

Thanks for any advice!

Easel can’t do 3D, just cut the clamps and file/sand the slope at the end of the clamp

Actually, easel can do 3d, but not in the way you described it. You would have to import 3d g-code from a 3d model of the clamp from a piece of software like fusion 360.

It sounds like what you want to do is make 3d paths, but using vectors and paths is strictly for 2d operations. Once you add that third D stuff starts getting more complex.

you can simply make the 2D part and sand off the sloping feature

Thanks for the help! I made the four clamps as described (sanding the slope) and they worked beautifully. Then I broke one and decided to try making the replacement as a 3D path using Fusion. That worked perfectly too, except that every time I import an SVG from iDraw into Fusion, the resulting file is 75% of the size it should be. I know that SVG files are just pixels, so I’d think changing the scale when I export from iDraw (now Autodesk Graphic), that would fix it, but Fusion imports it the same way each time (I guess its finding pixel per inch information in there). Changing the import scale in Fusion changes the size, but not in the way I’d expect. I have to use a scale factor of 1.1545 to get the right size, which seems bizarre. (I was expecting 1.33, or 100/72 or 100/96, etc)

Here’s a pic for anyone curious, using my old clamps to make a new one.

SVGs are not pixels, they a Scalable Vector Graphics (open one up in a text program and you can see all the math) Try exporting your design as a DXF and see if that works

Thanks, Glenn. I know they aren’t pixels like a bitmap, I just meant that the math is always stored in pixels, even if you’ve been working in inches or millimeters. That is, if in iDraw (Graphic) I draw a box that is 1" x 1" at origin, when I look at the exported SVG, that 1" has been converted into 72 pixels. Or if I open the attached clamp SVG in a text editor, the only dimensions are that it is 576 pixels by 576 pixels, even though in iDraw, the canvas was 8" by 8" (which is 576 pixels at 72 DPI). If I tell iDraw to scale the image up by 100% when it exports, all it changes is the dimensions to 1152 pixels and then all the math is relative to those pixels. Doing that to 133% seemed to solve the problem for @Rusty going into Easel, but Fusion 360 seems to ignore the upscaling that iDraw does.

I’d love to see if using DXF solves it, but I don’t think I have a program that can save that way. SVG is the only vector format that iDraw/Graphic and Gapplin seem to support.


What how big is that clamp supposed to be? The SVG above imported into Inkscape is 3.559 x 1.260 In or 320.315 x 113.386 pixels

Ah, interesting! So Inkscape is using 90 pixels = 1 inch, whereas Graphic reads and writes SVGs at 72 pixels = 1 inch. (Which explains the clamp appearing at 75% size, and needing to be scaled up by 133% in order to work with Easel.) I’ve read that some other vector programs assume 96 pixels = 1 inch. Clearly SVGs were designed to display web graphics on a wide variety of devices rather than maintain real world measurements for CAM. :frowning:

What still doesn’t make sense is why when I tell Graphic to scale the export by 133% that fixes it for Easel but not Fusion. Or why in Fusion I have to tell it to scale the imported image by 115.45% (!). Where does that number come from? Since Graphic and Fusion are both Autodesk products I’ve posted a similar question there, but haven’t gotten any replies yet.

Anyway, thank you very much for taking a look.

I just looked at MakerCam is says use 90 if importing from Inkscape and 72 if from adobe illustrator, not sure whats going on with Fusion. Be sure to let us know when you get it figured out

I might have missed something, but you could just model this in Fusion and then generate the G-code in Fusion as well. It shouldn’t take too long to recreate this in Fusion.

This is very interesting! I always wondered why my exported files were small. It hasn’t mattered much. I just keep everything selected after import and copy and paste the dimensions from Graphic into Easel, but it’s interesting to know why.

Very true. It’s a simple enough model (which I downloaded from the Inventables store), and then widened the slot and hole and added the chamfer. But as I learn Fusion, I’d like to be able to easily import SVG files anyway, whether I create them in another drawing program or just download them online.

To simplify the test, I made a 2x2" canvas with just a 1" square at origin. That saves to an .SVG file that is 144x144 pixels with a box that is 72x72. If I import that into Fusion, I get a box that is .75"x.75". But if I tell Fusion to scale the XY plane by 1.33, I get a box that is 1.33" x 1.33".

OH! The problem is Fusion squares the area of the plane in both directions at once. So to get a box that is 1" x 1", I need to scale it by the square root of 1.333, which is ~1.1547, which is what I found empirically. Interesting!

This is the same whether I tell Graphic to scale the SVG file when it is exporting or not, Fusion sees it the same. Loading the file in Inkscape, I get different results. The non-scaled SVG file from Graphic loads as 0.809" (not sure where that comes from) and the scaled up version loads as 1.076" (close, but not that close).

I’ve attached the two files if anyone wants to see if they get the same results.


That is some very unusual behavior. Leave to AutoDesk to make a simple task make no sense. Unfortunately, I didn’t get a chance to try this out last night, so I can’t say to much on it, sorry!

what’s the thickness of the material and did you get it?

I used a scrap piece of 1/2" oak that I had left over from another project. The first four I made in 2D and created the bevel with a sander. I later made a replacement in Fusion3D. This allowed me to use thicker wood (3/4") and have the CNC route out the unneeded 1/4" and also create the sloping bevel automatically. The end result is basically identical, but Fusion and 3D carving offer many more options for mor complex carves.