Huanyang vfd and 800w spindle problem

Hi everyone,

I recently had a problem with my cnc. I tried several things without success, I need your help.
The connection between earth and a damaged wire from the spindle created a short circuit. There was no smoke, the circuit breaker trips. I replaced the damaged wire and now I have the error A.oL and then E.oA.A. when I try to start the vfd.

My setup is: 220v, 800w, 5A, 400HZ, water cooled spindle with a Huanyang VFD 1.5kw. The cable between vfd and spindle is 4 core 16awg shielded.

The spindle seems to be ok. The resistance is 4.2Ohm between each pins (U,V,W not the earth).

Visually the VFD is ok. When I run it witout the cable attached to the spindle there is no error. I tried also to reset settings and apply it again. My setting is:

Do you have any advice to determine the problem please?

Thanks in advance for your help!

Will the VFD start with the cable attached to it, but removed from the spindle (if this is possible)?

Does the spindle move freely?

All phases to Ground (Earth) are OL/ Open?

The manual states that E.O.A.A indicates a Motor Overload (150%/ min.). I didn’t see the A.OL in the manual, but I assume it signifies that the Overload Fault was detected on Phase A.

If the VFD will start with the cable removed from it’s output it might be OK, but it could be damaged internally. Do you have a small motor other than the spindle to hook the VFD up to to test it?

Check the cable is not faulted internally; insulation between the phases may have broken down during the event.

Do you have a way to test the spindle with another power source?

Are these the recommended settings for your setup? Did you pull these settings from the VFD after the event?



Hi Brandon,

Thanks a lot for your help :slight_smile:

Here is a video of the settings and test I made for chinese seller that doesn’t reply to my messages…

Yes it is possible to start the VFD without the spindle and it works great.

The spindle move freely, I use it only a few times. Whern the spindle start (before E.OA.A. error) the collet vibrates.

All phases to earth are open and connections have been re-done.

Thanks, I didn’t though it could be that, but you’re right it could be the phase A the problem.

Sadly I don’t have any other motor to test it :frowning: I’ll try to disassamble the VFD.
As the resistance of each phases are equal and the vfd starts without the spindle connected, I thing this is a component of the VFD. Am I right?[quote=“BrandonR_Parker, post:2, topic:33072”]
Check the cable is not faulted internally; insulation between the phases may have broken down during the event.

Do you have a way to test the spindle with another power source?
I checked cable one more time and it is perfect, it was brand new (16awg). I checked also wires of the spindle connector and resolder them all to be sure.
No, I try with another 230v input, but I’m still searching for another way to test it.

This is the recommended settings yes. This was the setting before and after the event. I tried to reset and reapply them to be sure. I had also tried several other settings without any success.

Thanks again for your help Brandon.


What do you mean the collet vibrates prior to the VFD activating the E.O.A.A error?

Was it Phase A that experienced the Ground (Earth) fault?



This is the phase that had problem:

By “vibrates” I mean that it doesn’t turns, it move forward, backward rapidly.
But It think I find the reason. I found a transistor (kdg15n120h 20140127142750420.pdf (310.9 KB)) that has exploded!

What do you think ? Is there a chance to save the VFD by replacing this transistor?

Thanks for your help.

That would definitely be the problem!

It appears that the Phase A - Ground was of sufficient magnitude/ duration to blow the IGBT to pieces. It’s interesting that the controller of the VFD did not have sufficient enough protection to prevent this on what I would assume would be the first Instantaneous Over Current the IGBT experienced. That being said, considering that the designers/ manufacturers have added solder to some of the traces in an attempt to increase the amount of current they can carry indicates that the VFD is not of the greatest quality, but I’m sure we all here are aware of that.

You could definitely replace the IGBT and give it another go, but I would definitely look over the circuit boards extremely thoroughly and give special attention to anything that appears to be overheated.

Please let me know if I can be of any further assistance…

If you think this is bad you should see what an Allen Bradley 700L Grid Tie Inverter looks like when its IGBT’s decide they have had enough; it’s insane…



I’ll try to replace the two IGBT on the same phase. The other one after a quick check is in very bad condition.
Circuit tracks seems to be good. It’s difficult to be sure that everything works but I want to try :slight_smile:

Ahah this is crazy!!! I feel lucky to just have two parts broken now :slight_smile:

Thanks for your support! :beers: :grinning: :thumbsup:

Good Luck!!

Keep us informed of the progress please.

Now here’s a blown up IGBT… :open_mouth:

This is not from the device I mentioned before, but it is a large type of power IGBT that I work with.



Huanyang VFD Please Help with Problem

Hi All,

I have just purchased a Huanyang 2.2KW VDF, the first time that I have powered it, I went over the various parameters and I was able change the values accordingly. The second time (different day) that I have powered the VFD, all the parameter values displayed “NULL”. Once Null was displayed it went to the next parameter and I was unable to change Null into any value.
I even tried to set PD013 to 08 (which resets to factory default settings ), but I was still unable to change Null into any value. I have also tried to press stop to ensure it was not on run model.

Your help is much appreciated.

Hey…you should start a new thread that way your issue can be addressed by itself and this thread will remain as the the OP’s problem/ resolution.

I’ll be more than happy to chime in on your new thread.




WoW! That’s a blown up IGBT :confounded:
I replaced the two IGBT with similar one. I had to wait to receive them from china…

Now, I have to admit that I’m a bit afraid to test it. I double check everything but would like to have any advice how I could test it securely. Maybe you could help me :slight_smile:

You might first try starting the VFD with nothing attached; measure the output voltage of each phase if you have a DMM.

Then if that works hook the spindle up and run the VFD in manual stepping it up in small increments measuring the voltage/ current for each phase to make sure the output is balanced.

Considering that the VFD powered up previously with the two failed mosfets I would assume it is probably still OK.




Good news!:champagne: After replacing two diodes, one resistance and two IGBT, the VFD works perfectly. I hope this will last…

Thanks for your help!! :slight_smile: Very happy to see it work again!

1 Like


I’m glad it is working for you again…




i know this is an old post, but I, recently facing similar problems (100% similar)…and im trying to find suitable information for the repair component that you have used for the repair.

i already purchase the IGBT, but im confused about the suitable diode used for the circuit.

p/s : does your VFD still working after the repair?


The VFD worked great after the repair. Today I use a 2.2kw spindle so I don’t use it anymore.
I used kdg15n120h IGBT. I have to check for the diode… but are you sure they are not working? Maybe you don’t have to change them…
Pay attention to the thermal pads and how you solder the IGBT to have a good attachment to the heatsink. Check components around the IGBT to be sure nothing else is broken.

Please let us know if you have succeed to solve this. Cheers.

yeah…im pretty sure its not working… i have tried replacing the diode with zener diode, but it trips my circuit breaker whenever i start the vfd.
all parameter has been set according to motor nameplate and my ac input

I replaced with a diode with the similar value. Be sure nothing else is broken(components, pcb,…). The other IGBT are ok? I had to replace two of them. How did you get this problem?

the other IGBT are ok, however, i only change the damged ones.

I think the problem cause by the wire in the gx20 connector…might have some shortage, for a few sec the spindle is working, but then, i got E.o.C.A error…

2nd try, the motor doesnt spin, and only move a little( like a vibration) !..i get E.O.L.A error code…

now i need to find the correct value for those diode…cant find the specification anywhere in the web