Importing Grayscale SVGs Comes in as black

Hi Easel community!

I’m trying to Convert a really intricate Heightmap I have into a grayscale for Easel.

I have this:

and after some postprocessing in Inkscape, I’ve converted them to different grayscales that will give them the height that I want. -

importing it does this:

This is a large and time consuming project, so Manually changing the colors, while time consuming, is necessary, but I can’t work with it in Easel. It would be too much manual labor to do it all in there. Ideally I can make this all happen in an inkscape file, and import it to toolpath it in easel when i am happy with it.

I did the “Break-Apart” → into “Union” so that there are no holes, but it still doesn’t seem to want to import the color. The SVG opens into a web browser with color just fine.

Any Ideas?


Robin, Easel is setting the cut depth for each path to clear out a pocket. I believe this is because each of the vectors is a solid color rather than just an outline of the vector.

To be honest, if you plan to use Easel to post-process and send to machine you will have a lot of work setting each vectors cut depth. If you plan to make a 3D topo then you need to import as a 3D STL.

I have not used Easel for very long so I am a bit rusty on all the features so stay tuned and others will reply to this thread soon.

1 Like

Robin I did a quick experiment to verify I was giving you correct information and here is my results…

If the SVG you import is grayscale with solid colored vectors it will import each vector with the cutting depth 100% and “clear out a pocket” even if it is just light grey.

If the SVG you import is just an outline without any solid colors it will import each vector with the cutting depth 100% and “cut on shape path”.

I used these two svg’s for import:
Grayscale-Shutter-Icon (1)
Outline Only:
SVG Outlines

Here is the result in this shared project:

I hope this helps.
Robert Ketter

1 Like

I think I understand your issue. I’m not sure what @Robert10 is getting at, so maybe I’m confused.
This is what you’re going for, right?

If so, can I guess that you originally started with a non-inkscape SVG?

Easel should set each shade of grey to a different depth. @Robert10 Try your example again without the gradient fill…use a different shade of grey for each segment.

1 Like

Hi @NeilFerreri1 -

Yes, It is what I am after.

Yes, the Topographical map was originally not an inkscape file. I am copying the rings over, and coloring them by hand to have them match the exact grayscale I want, then exporting from this new document.

I’m not getting the result you are however… What did you do to make that work?

Edit: I’m not really finding any youtube tutorials on grayscale SVG importing… does that mean I should be importing it as a different file type?

This is actually sort of a broader issue with Easel, which is that I’d like to have the ability to set a height based on 0-1 space without having to do the conversion based on it’s height. Or the ability to make a height “swatch”. Ideally this is just done in inkscape as i’ve done, but I’m not sure what i’m missing to import the shape not black.

I had to modify the SVG output with a text editor. I can send you what I did later when I’m at a PC.
Do you have the original SVG that you started with?
How did you save the file in inkscape? Just as an inkscape SVG?

Basically, there was an issue with your specific SVG. Not an inkscape issue, not an easel issue.
If you are planning on doing more of this, it’d be helpful to understand how the SVG was made, step by step.

I was using Export → Inkscape SVG, as well as “Plain SVG”

here is the SVG file.

Edit: I forgot that I tried color thru line only, but i had previously set the fill color to the same as the line color, and also attempted to have zero lines.

Did you create that from scratch? If so, how.
This actually might be an issue with easel. Either way, I’ll send you how I fixed it later… It was a bit to figure out, but it’s easy to do. I just don’t remember the SVG standard off the top of my head

1 Like

I copied the Rings over from the SVG that is in the heightmap in the top image, into a brand new inkscape document. I then manually set the fill for each of them in this document, and then used “Export”.


Where did you get the rings is what I’m asking? Was the original topo an SVG or did you trace a bitmap in inkscape?

They’re derived from a PDF.

Whole CampNew.pdf (3.2 MB)

1 Like

Sorry for getting to this so late. I figured you weren’t waiting on me, so I explored this a bit more.
It looks to me like the SVG style property “fill-opacity” is causing the problem. This is not an issue with the SVG as far as I can tell, and I’m not sure I’ve seen this issue here before.
Two ways I think you can work around this for now. The first is what I did to create the screenshot above. In a text editor ( I like Notepad++ or Sublime, but Notepad should work just fine), do a find and replace (Ctrl+H on most Windows programs) and replace fill-opacity:1; with nothing. Then save. This will effectively remove the property from the SVG, and Easel will load it correctly.
The second way is to save the SVG as an “Optimized SVG”. This will remove the unneccessary property and load into Easel. My Inkscape settings, and version, are different from yours, so this may have different results for you. The text editor method worked with your file without ever opening it in Inkscape.
Anyway, here’s the modified file:

This might be an issue with Easel’s handling of SVGs. @JeffTalbot @KacperMarcisz

1 Like

Wow!! Thank you for doing all this!!

I also realized something-

something I tried was to use Swatches:

The Right uses Swatches, while the left doesn’t.


That actually doesn’t translate to true color… Interesting finds.

Edit: Further digging. If I individually select the layers and click “color fill” from “swatch fill”, it keeps the color but fixes the issue. so swatches are stored differently I guess.

Thanks for digging!! It at least sets me on the right path, and I hope this thread helps others.


Yup, using swatches was the only way I could replicate the issue. But once you click on swatches, there’s no going back.
I teach inkscape and my students find every possible (and some impossible) ways to jack things up. I’m used to digging into these things, and this issue wasn’t too bad.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.