Importing .svg files

I am having trouble importing svg files into Easel. I create them in Inkscape from pdf files and then save them as svg files. When I import them into Easel and then try to change the cut from ‘on the line’ to either inside or outside it says that it’s unable to change as the lines need to be ‘joined’. Can anybody tell me how to do this in Inkscape as I must have tried everything but to no avail. Now getting desperate!

@AllanFryer Can you share the svg here?

Rocket Car
Hi Neil
Not sure if this link will work? Just simply want to cut the outer line on the outside and not on the line. As soon as you try to change it it comes up with the error message “If you’ve imported an SVG, check for open paths and join them before importing.” I cannot seem how to work out how to close the ‘open paths’. Any suggestions would be gratefully received.
Thanks
Allam

Hi Allan,

The issue should be fixed below:

https://easel.inventables.com/projects/c4UJODDAtMpQp32jn11_Hw

While it looks like you have a closed shape, you really don’t as far as easel is concerned. It looked like the path was discontinuous. So what i did was combined the path with another random shape. This effectively “closes” the path and now you can choose “outside” path.

Cheers,
Ethan

Hi Ethan
Thanks for that but I have a lot of patterns like this where the same thing is that occurring. Sorry to be such a simpleton but exactly how did you do this. Was it done in Easel or in Inkscape. Either way I’m at a loss on how to do it.
Look forward to hearing from you

Allan

I think Ethan is saying that there is a tiny gap somewhere on the outside of that shape, I may be wrong about that.
I have had this message before though; to solve it on this image, highlight the image, in Apps select Offsetter, set distance to 0 and keep the original if you want, then import. That should sort it. The problem might only be on this image, others might be fine.

Hi Allan,

I was able to do it in easel. After importing the svg, I clicked on the first outer shape and set it to fill. I then created a circle element and dropped it inside the shape. Then i selected both shapes, did a combine operation, and then with the new shape set it back to outline. Doing the combine seems to fix the issue. One thing i did notice was that after importing the svg there are several small paths along the outline of the outside path. I found these one by one and deleted them.

Hope that helps. let me know if you need anything else or if that didn’t make sense.

Cheers,
Ethan

1 Like

You have a handful of extra paths, delete those.
There’s a small gap near the area where the slope of the hood gets steeper.
In Inkscape, reduce the stroke width to something like .01mm. You’ll see that gap.
You can connect and combine the nodes to make a continuous shape.

Another way would be to, in Inkscape, convert the thicker stroke to paths and delete the extra path generated.

Hey guys. I’m having the same trouble when importing an svg file generated on Adobe Ilustrator.
When I select an object and try to change the cut path form On Shape to Outside Shape Path, easel gives a message saying to check for open paths and join them before importing.
The original file was generated by Shape 3D and i can’t see any open paths.
I’ve done this process many times in the past, but this is the first time I’m getting this message.
I don’t know how to fix this. Any ideas?
Cheers,
Xande

I’d zoom in as close as possible on the lines and look for a break. There probably is an open line, it could be a pixels width but that’s all it needs to be.

1 Like

Hey AdamBeech. Thank you for your reply. I checked all the lines and they are all solid. No open lines or broken bits. I also tried to “highlight the image, in Apps select Offsetter, set distance to 0” as you recommended on an older post and i also didn’t work.
Any other tips I could try?
Cheers,
Xande

1 Like

You can upload a .svg here as well, that might help identify the issue…

Hey SethCNC. Thanks for your reply.
Please find attached the sgv file.
I can change the cut path form On Shape to Outside Shape Path for the longer object. However, when I try to do the same with the smaller objects, easel gives a message saying to check for open paths and join them before importing.
:thinking:
Thank you.

Xande's Model Round PIn Jul-22_hollowplan new update

So looking at the .svg none of the shapes are actually closed, they all are open vectors as a result Easel does not know which side is the outside or inside to apply the toolpath to.
The First and Last nodes are atop each other, BUT the paths are still open.

The proper fix is to close them within AI before saving the .svg
I don’t use AI so I’m not totally positive how it’s done, but by googling “close path Adobe Illustrator” quite a few articles and videos came up which might help…

HOWEVER one can also close them within Easel (sometimes) by using the offsetter V2 tool, setting the offset amount to 0 and unchecking “keep original”

My kids are watching TV so I didn’t record sound here… but it still shows the process required… You could de-select the top arc for this OR place a 0 depth shape atop the newly added line (required to close it up) and use that 0 depth shape as a sort of “masking” to prevent the toolpath from generating there. . (up to you)

Hey SethCNC.
Thank you so much for your reply and for the video mate.
There is so much for me to learn in that video.
Thank you!

1 Like