Initial cut to deep

Two times my machine have done the first cut far to deep. The first pass should be 1,5 mm but it cut 9,5 mm. When I went back to origo and started over it went just fine - but a nice piece of wood was already ruined. I run from G-code but I assume I have done something wrong in Easel - or Easel might do something wrong.

Anyone who have encountered this?

How are you zeroing your z-axis (tip of bit to surface of workpiece)?

are you sending from Easel or are you sending from a different g-code sender like UGS? I ask because you state “I run from G-code” which implies that you sent with something else.

If you are “run from G-code” do you have the command to send in inch or mm in the g-code?

The command G20 set the machine to use Inches and the command G21 set it to mm.

also here is the link to supported G-code command in easel.
you can note that they say to make sure you specify the inch or mm code to make sure you get the correct setting.

I work in Fusion 360, all metrics. Then I import the G-code to Easel.

I’m sure there is nothing wrong with the G-code or the machine itself; I run the same piece often but it have gone wrong two times of approximatelly twenty runs. So I suspect I do something wrong in the Easel process.

I have of course zeroed it properly.

And again: it works 90 % of the time.

This is still a problem… annoying. I was about to show it to my CAD/CAM master/friend - but then it of course didn’t occure. I tried several times but it worked all the times. Today I was going to the same G-code and then it goes down 5 mm, not 9,5 as the last time.

Any theories?