Initial Setup Homing Switch Problem

Hello everyone. First, let me say that I am a complete newbie when it comes to CNC and all the terminology that goes along with it so please bear with me. I’ve been reading different threads on here for the past couple of days and I can’t find an answer to my specific problem. I just finished putting together my X-Carve 1000mm and have installed the software and drivers and have now gotten to the initial setting up of the machine. I have the Limit Switches (Homing Switches) and I can’t properly home the machine. The Z-Axis does just what it’s suposed to do (brings the Dewalt 611 to the top, engages the switch, motor stops, then brings the router down just a bit and motor stops again). Then the X and Y axis begin the sequence of bringing the router to the lower left corner but once either homing switch enages the actuator on the X or Y-Axis (depending on which gets there first), it stops but the motor just keeps running and prevents the final Axis from finishing up the procedure. I’ve checked all the wires, soldering and common ground connections and they seem to be fine. Do I have bad homing switches or is there some other reason for this problem. Thank you in advance for your comments.

Rob - you should be able to check the homing switches by manually engaging them and then dump their values from grbl. I think you can send ? from a terminal and get the limit switch values (doesn’t work with UGS - just tried). I know you can use gcode with Marlin to get the values (M119) but I don’ know about grbl.


Take a look at this thread:

Thank you for the information Larry. I seem to be having problems getting to the State of the Homing Switches as well. I am using the Serial Monitor in the Arduino IDE. I have set the baud rate on Com Port3 to 115,200 in Windows. When I open the Serial Monitor I get the following: Grbl 0.9i [’$’ for help] and [’$H’|’$X’ to unlock] underneath it. The same 115,200 is set in the Serial Monitor. When I input $ and hit enter or send, nothing happens. When I input $$ and hit enter or send, nothing happens so I can’t get the values to change the Status Report Mask. On a positive note, I took the time to replace all of the homing switch wires with shielded cable as I had read that sometimes interference can be an issue and I do have the blue light and all three green lights on. I also now get a proper homing with both the Z and X axis so it’s just the Y homing switch that is now giving me fits. This is what happens when a woodworker like me tries to be a computer tech guy GRRRRR.

Make sure that in the serial monitor at the bottom of the screen the end of line value is set to Newline.

Thank you Larry. I will check that in the morning and report back my progress. These old eyes are barking at me and telling me it’s time to call it quits for the night.

Are you clicking the $X button in the UGS command tab then clicking the $H. Also if you have an ohm meter or continuity checker you could see if switch is working.

I believe I’ve narrowed down the problem. I tested the voltage on the X and Z axis and I have nearly 5 volts. I had 0 on the Y axis. So I checked all of soldered connections for the Y axis homing switch and they all looked good. So then, I tested the board itself where I soldered the 8 pin connections. I had 5 volts at pins 2 and 5 but nothing at pin 3. So I re-soldered at Pin 3 and it still reads 0. So at this point I believe I have a bad gshield rather than it being seated improperly because everything else works on the shield (Blue light, Green lights, X and Z axis etc.). I will have to order a new one unless someone has something else I can try.

Can you send a picture of your plug and wires going to shield

You can test to see if the problem is the gShield or the Arduino. The gShield just passes the Arduino pin up to its level. Take the gShield off the Arduino and measure the voltage on the Arduino to see if it is good there. If not, then the problem is the Arduino and not the gShield.

MRoss, here is a photo. Larry, I didn’t think it might be the Arduino. As a side note, I tipped the plug sideways and connected the Y axis pin (number 2) to the plug in hole 3 and tested at the Y homing switch. I had 4.87 volts. So it’s definitely a problem at the pin 3 location either on the gshield or Arduino. Later today I’ll go back out in the shop and test the Arduino.

Looking at the picture there’s no ground wire in the connector. Did you hook the black wires from the switches to ground at another location?

Also, check to see if pin 3 is shorted to pin 4 where you soldered them on the gShield.

The ground wires for the switches are connected to the main ground terminal where the yellow arrow is. There is no short between pins. I checked that first before re-soldering and then made sure of that after the re-solder. Heading back to the shop to test the Arduino.

I just tested the Arduino Voltage for corresponding pins 2,3 and 5. All are giving me readings of 4.90 volts.

Ok, there is a problem with the Arduino to gShield connection, or a short on the gShield. Examine the pin on the gShield that would plug into the pin 3 position to see if it is clean. You could use a pencil eraser to burnish the pin and see if it will make better contact.

I decided to just order a new gShield. I could spend a few more days trying to figure out if it’s a short or not and end up no further ahead so it was worth the $50 to have that piece of mind. My soldering is anything but top notch but it’s not terrible either. Just to be on the safe side, I’m going to have one of the techs at work who solders stuff every day do it. That way I’ll know it’s done right. I’ll post back when I have the new gShield and everything is hooked up to report if the homing sequence works. Thanks for everyone’s help!

Might want to hold on to the old one as a spare. You can do a lot with the system without homing switches working. Just a different operating procedure.

I plan to Larry. Always good to have a backup!

I got the new gShield and soldered new pins onto the new board. Hooked everything up and tested. I had 4.87 volts at pins 2,3 and 5. I then hooked everything up and ran the Homing sequence. Success!!! I’m still not sure if it was a bad solder or a bad gShield but either way, that problem is resolved. Tomorrow, I’m on to the calibration of everything and then the test carve! Thank you for the help TheGuru, MRoss and LarryM. More importantly, have a Happy and Healthy New Year!