Inventables Community Forum

Install error with Easel helper app on DIY CNC

I am getting a “non sucking service manager” error from windows when I try and run the helper app that EASEL asks me to install before trying my first carve.

Suggestions? Computer is an XP machine.

Thank you for your patiance with a Noob question.

I believe it is 0.8. It was the local driver that was causing the error . It dies at the very last step of the installation. Going to retry with Win 10 machine.

please post response if it worked or not so that we will know the results. Have never heard of this error before.

It installed fine with Win 10 laptop. I did several fresh installs with my XP laptop and they all feailed with that “non sucking service manager” error at the VERY end if the install

I can load the “Smiley” file and am trying to get DIY CNC to work with Easel.

Let me make some assumptions … please let me know if they’re wrong:

  • I should be able to have SOME level of functionality even though my machine is none of the three choices in the machine setup instructions. I don’t know the thread pitch and the rod diameter is none of the choices.

  • Do I need ANY additional software on this laptop to enable EASEL to manipulate the engraver? I had cnc controller on the other laptop and I was able to load an nc demo file and see it run.

I really am hoping I can use easel for my purpose. It’s just what I need (PCB etching) if I can get thru the rather steep learning curve of all of this.!

Thanks again
John

Thanks…

To be honest I’m not sure which version of grbl is on the controller/Arduino . I could plug back my other machine, run GRBL controller and see if I can find out that way.

There’s a LOT of variables to get this going. The machine I’m using is in my avatar photo. I may upgrade once I figure out if an engraver is feasible for my purposes.

OK… installed 3.2 and that seems to install OK.

Nothing happens when I try to connect, but that’s the next issue to work thru.

OK… I just ran GRBLController again with a file I downloaded. While I have the spindle off, I can verify settings…(com port, speed, etc).

No go on getting Easel to communicate yet, but I’ll keep at it.

Tried a different browser. Not the issue. I know what COM port its plugged into but EASEL must poll them as I don’t see a way to define them.

grbl is 0.9. Now going to see if I can export code manually, paste into GRBLCONTROLLER … it’s a kludge but at least I can see if the code Easel generates will run well on the engraver

code exported from Easel to grblcontroller runs fine with engraver, so …the problem remains communicating from Easel to the Arduino /Shlield

Hi there,

Just a quick note that Windows XP is not a supported platform for Easel. You can view our system requirements on this page: https://inventables.desk.com/customer/portal/articles/2052875?b_id=9562&t=0

Microsoft itself stopped supporting Windows XP in 2014, and in order to continue improving the software the way we want, we cannot continue to support it either.

Jeff