Installing Gcode

I just bought an 1000 mm x 1000 mm X-carve Kit. I also purchased V-Carve Pro and only now i realized that i cannot send to carve from this software to the X-Carve. I read a little about Gcode sender, but it lost me at some point (i am really new to this, i only worked with programs from foam cutting and cutting plotter that have a software which cuts directly). Can anyone tell me what to install/do after installing the Arduino Uno drivers?

I would highly recommend you use Easel to cut a couple of test patterns, just to make sure everything’s working and you’re getting accurate results.

After that, here’s some info that might help:

You’ll want to read this thread about how to set up V-Carve so that it has the correct settings to work with your X-Carve - V-Carve Post Processor

You have a couple of popular options for running the gcode that V-Carve will produce. One of them is “Universal Gcode Sender”, and you can find some info about it here

Another popular option is Chilipeppr, at ChiliPeppr - Hardware Fiddle. You can proably find some youtube tutorials to help you out with it.

1 Like

Thanks for the advice. I already tried Easel and it’s working great. I’ll try to set up V-Carve and see if i manage also with Universal Gcode Sender.

I uploaded the Arduino Uno processor into xloader and after that started the Universal Gcode sender and now i cannot use Easel anymore. It doesn’t find my port. Could anyone help me please?

If I understand your dilemma,

Easel is a stand alone program for design and the operation of the x-carve.

Universal gcode sender (UGS) is used for sending code to the x-carve from another design program such as vcarve pro or aspire.

As you have discovered, having both easel and UGS open at the same time causes bad things to happen.

So, if i want to use Easel again i have to connect from another computer that doesn’t have the UGS connected to the X-carve or just use the UGS?

Also, when i connect the UGS there is an error that appears

I tried putting at BAUd 115200 but the X-carve won’t work

and the spindle won’t spin also…

This coming weekend I’m going to put together a tutorial on using UGS, specifically for X-Carve users. You can use Easel and UGS on the same computer, and you don’t have to uninstall anything, but they can’t both be open at the same time.

@ConsuelaSabau in your last screen shot, it looks like you still have your Chrome browser open. If Easel was running in your browser, it would cause problems with UGS. Also, if UGS was running, and you tried to use Easel, it wouldn’t work.


Can’t wait for the tutorial. i’m really really new to all that is about gcodes and toolpaths.
The chrome browser is closed, but the error still appears in the UGS and easel is not working also. Probably is better to reinstall Windows 7 and the arduino driver

I reinstalled EaselLocal but cannot find the port and the spindle makes an easy sound like it’s blocked but wants to move. Does anyone know what would be the problem?

You might try contacting Inventables directly, here’s their info:

I’ll do that. Thank you

it seems overwhelming at first but this CNC stuff takes a bit of time and practice and will all start to make sense eventually

1 Like

This tutorial ever come out?? I could use it. I have successfully loaded gcode from vcarve photo. But when i tried to run a toolpath from aspire it went bad… z axis shot straight through project and waste board. Lol. I pulled the plug, quick. I could use a ugs lesson

1 Like

Did you find it? I would like to see it.