Issue loading gcode into Easel

Hi everyone,

I’m trying to get my first project to load on my new X-Carve Pro but am running into issues. Hoping you kind folks can help.

I’m using Vcarve 12 and have set up the program to output to my X-Carve Pro. I’ve tried outputting a couple of files - one was a purchased file from Etsy, and the other was a simple logo I created. Whenever I try to import my code into Easel, though, I am getting a syntax error.

I’d appreciate any direction you can provide. LMK of any additional information you may need in order to advise.


When you select “gcode import” within Easel, if you scroll down at that initial popup page there are instructions regarding the post processor required when using Vectric software as the CAD/CAM and Easel as the sender. Are you using this required post processor when saving the gcode file?

Hi Seth, I’ll look into the gcode import in Easel this afternoon after I’m done with work.

I did change the pp in Vcarve last night, at which point I was able to import my file into Easel, but when I tried to run the file, it got two minutes into an 18 minute job and just stopped. It was encouraging, however, to see that I was able to actually import my file and get at least some of it to run.

I’m confident that with the help of this community I’ll be able to get this up and running - looking foward to getting more comfortable with the software.


Edit: thanks to some assistance from Ken4, I was able to get Easel working. Never mind that he was trying to get me set up with a different PP when he led me to my mistake. I think I will try a different post processor at some point, but for now, I’m just thrilled I was able to get a test carve to run successfully!

Make sure that there aren’t Gcodes that Grbl doesn’t recognize.

Grbl V1.1 Quick Reference –

1 Like