Issue with Fusion 360 export to Estlcam

Hello every body,
My name is Zhengwei and I’m a wood worker in China.

Very recently, I built myself an Arduino uno 3 based cnc machine. I’m using Fusion 360 for CAM and Estlcam as the G-code sender to my machine. In the past three days, I have tried to post processing all the file types that Estlcam can accept, and the results were not pleasant. In the tool path preview window, the paths were not looking correct with broken lines and shapes. I ran the machine and indeed it made a mass and almost broke my tool. Only one or two Post processor I tried with a .nc file were usable but no code generated on drilling operation.

The EstlCam version is 11.009, I’m still on testing, I haven’t purchased the software. I tried to export with GRBL processor in Fusion 360 and have the file open in the Universal G-code Sender, the tool path looked right. I don’t want to give up on EstlCam.

Below is the tool path simulator in Fusion 360

Below is the tool path preview in Estlcam, post processor used in fusion is GRBL , the tool path is broken and looks like no drilling tool path.

I have tried mach3mill, linuxcnc and a lot more, the results are mostly the same or worse, well, it’s same since I can’t run the program.

I’m really new to cnc, Could anyone help me please?

Best Regards

hello, I think I got the question answer by myself. I searched the forum on CNCWERK, it is written in German, thanks to google translator, I found someone else already had the same problem I’m facing. EstlCam can’t take commands of G17-19. That’s why my tool path were messed up. :slightly_frowning_face:

Now, Solution A is to edit the G-codes Solution B is to edit the post processor, which is even harder for me right now.:weary:

again, can anyone help? or just advice please

Try emailing Estlcam and asking them for a post processor.
They sent me an Estlcam post processor.
It works.