Issue with the new Easel driver and Xcarve wireless

Looking to gather some info from anyone who may have fixed this issue similar to mine. I have been using raspberry pi as a server for my xcarve. But recently I downloaded the new driver from easel. At first I thought it was my Nodejs version or my raspberry pi. I think I flash the pi a dozen times. Week later and hours of testing, no result. But found out by accident, cause thats how it always happens. That if I remove the new easel driver from my library all together I end up with a working easel connect wireless to my XCarve. I have a local Library and User Library which I thought at first files were installed in the wrong place. only I thought that was because when I installed xcarve-proxy and forever files to connect to the pi were installing in the wrong place because my Mac has two sets of Libraries.

If anyone can point me to a way to fix this it would be greatly appreciated.

And if you feeling supper smart and know how to connect my UniversalGCodeSender to my Raspberry Pi wirelessly, I would be obliged to give you a hug through the computer.


I use a raspberry pi at home to connect to my xcarve, when I want to use Universal Gcode Sender app, I have the UGS installed in the Downloads directory on the raspberry pi, then I use secure scripting host “ssh” to start a session remotely on the raspberry pi with the -X variable. when I have a connection I then start a remote x-server session “startlxde” and navigate to the Download folder and execute the file which in turn runs the Universal Gcode Sender program. this way I have a nice graphical user interface “GUI”. you can also just Google start remote x-session raspberry pi for more detailed instruction’s as there are many different approaches to accomplish this.

Just wanted to note that this approach requires an X server on the desktop machine you’re connecting from, so I’m guessing you’re running either Linux or Mac on your desktop - Windows doesn’t support X, so “ssh -X” won’t work on Windows without additional software.

And I’ve never heard ssh called “secure scripting host” before, it’s always been “Secure SHell” to me.

First, thanks for the extra advice. I’ll dig into those suggestions and see what I can get from them. I personal loath coding because of how bad I am at it. Takes me twice as long to code as any 11 year can probly do and I’m a computer animator.

Is the ssh command for controlling the pi a GUI interface popping up once I start up the UGCS. I have never actually been able to start UniversalGCodeSender on my pi. The java oracle doesn’t seem to want to start it. Just seemslike I’m picking one once useful tool for another tool I can’t seem to start either

Is the UGCS running on my mac as an emulator.

StevePrior is correct that the machine that you use to connect to the pi must also be running an X-server, I have Google windows x-server and there seems to be several options available if you have to use windows to connect. I have been using Linux since before there was an x-server, and I am still learning. and ssh is for “Secure Shell” I was thinking of an acronym from windows which I have to use at work.
When you connect to the Raspberry Pi you can start your desktop environment with a command, I use “startlxde” then a GUI will start and run on top of you local machine and you will have whatever program you have installed on your Raspberry Pi run on your screen “even if it is not installed on you local machine” as if it was. all this does is forward the screen that you would have if you were at the Raspberry to the screen you are sitting at.

The UGCS is running on the Raspberry Pi. you “see” the program as if it was running on “your mac” you do not have to have UGCS installed on “your mac”. I find that this is very useful when running long code that web based control program can not handle due to the 5 meg limit on web browsers “I know there are workarounds but this is easier and quicker” when you use programs like chilipeppr or cncjs. both of which are great programs in there own right.