Larger 3D Cut

I have a large 3D cut that I am doing of the state of MT. The rough cut went well and now I am trying to do the finish cut. Easel seems to stall on generating the cut paths but after refreshing a few times it finallly does it. However, when I go to start the finishing cut. Hit Carve. The browser hangs and ends up on the Easel page showing the job and what looks like the page where you can watch a demo of the cut. The spindle is spinning but never starts.

I suggest downloading the gcode then import that gcode and then carve from that.
No more waiting while the spindle is on.

Hi, thanks for the response. It was good timing I was out trying something else. I did try to down load theh Gcode and import it. Same result. The Easel UI hangs after hitting Carve, The browser(Brave) throws a NOT RESPONDING error a few times. I hit WAIT. It ends up back on the work page where it looks like you can watch the tool path and it does nothing.

Brave?? Try chrome or Firefox

So… I’ve tried several browsers with the same result. Is there no other way to to run the finishing pass. I’ve downloaded the GCODE for the Finishing pass and imported it into universal GCODE Platform but can’t get it to connect to my machine. I had read in a previous post that a change to X-Carves caused it to fail and a baud rate change was needed.