LarryM build - hardware works, on to the software

Just so I don’t forget something along the way I’ve decided to post any problems that I find.

Ordered my X-carve on May 31st and received it on July 1.

Today I encountered my first problem. The 10 position barrier strip that came in the wiring kit doesn’t have the proper dimensions to fit the threaded holes on the X carriage extrusion.

Solution: I drilled out the mounting holes in the barrier strip using a 13/64 drill bit. Left plenty of material for the screws to mount the barrier strip. I drilled both holes a little so that I didn’t drill out to much material on one hole.

Started with a smaller bit and stepped up by 1/64 at a time until the screw holes lined up.

On to the next…

1 Like

I found this issue as well it seems the plastic is a bit warped. I just brute forced it , no drilling.

since the terminal strip is not position critical component, I simply enlarged the holes a bit to allow a bit of wiggle room

Same finding here. The holes were so close though that I got the screws to start/finish by putting them all the way through the strip first, starting both screws in their holes, then tightening them both a little back and forth until done.

Just a note: In the written instructions for attaching the NEMA 23 motors to the Y-Plates it doesn’t say anything about attaching the pulleys to the motors.

For me, the alignment was bad enough that I decided not to try and force it. Putting plastic parts under that much strain will eventually cause a failure. With the drilled out holes there’s no strain at all.

Just the way I did it.

Yes, I also encountered that slight misalignment with the terminal strip.

I just finished up work on the gantry. One thing I noticed and used is that the core components box is just about the right size to hold up the gantry as you are putting things together.

Also worked best for me to completely tap the holes in the Makerslides and then go back and do the assembly.

Had to take a break.

I’ve got most of the mechanical assembly done.

The two spindle related wrenches that came with my kit don’t fit. There is a spindle wrench that support knows is wrong and is working on a replacement, but the collet nut wrench does not fit either.

Build resumes on Friday with the wiring (waiting on some electrical parts I want to add).

Ok, I’ve gotten all the mechanical assembly done and all of the wiring. The last step in electronics says

Make sure both switches on the interface are set to off and double check all of your wiring (especially the placement of red and black wires). If you’ve wired everything correctly, the blue lights on the gShield should light up!

Well, if all switches are off and the USB cable is not plugged in there’s no power so how are the blue lights supposed to come on?

Is this just a foul up in the instructions? Should they have said ---- turn on the power switch and if the blue lights come on then the wiring is correct?

USB plugged in…

Thanks, TonyNo.

Now I’m stumped again. I plugged in the USB connection and nothing happened. No “New Hardware Found” etc.

So, I unplugged the gShield from the Arduino and then plugged the USB connection back in. Ok, new hardware found. I installed the Windows 7 driver and thought I was on my way.

Plugged the gShield back in, plugged the USB cable back in - Window 7 did not see the device. No COM port.

Unplugged the gShield and plugged the USB cable back in. Device manager sees the Arduino.

I think I have a bad gShield, but thought I would check with the forum before asking for a new one.

Does the 24 volt power supply have to be on with the gShield installed to get the Arduino to work?


Got a little farther. Decided to try the 24 volt supply and the blue light did come on. Still unable to connect to the Arduino with the gShield attached. Time to try the help desk.

As I recall, And I may be off base, it would not be the first time since getting the x-carve together was a wonderfully enjoyable blur.

I seem to recall the need to download drivers from the arduino website?

After I had them installed the computer fond the arduino with the gshield and the com port.

Yes, I did download the driver and when the gShield was not attached I could install the driver and that part was ok.

When I put the gShield back on the Arduino then the computer could not see the port anymore.

Take the gShield off and the port returned.

Ok, my bad.

Problem was that the gShield was not positioned correctly on the Arduino. Since it’s a blind install it’s difficult to align the two boards. If you twist things around and have three hands you can get things in a position to see one pin and socket that match.

Just a note to be careful at this step. If your port appears and disappears with install or removal of the gShield the position is not correct.

Also, in the correct position you have the COM port attached on your PC and with the 24 volt supply turned on you get both the blue LED and the green LEDs lit up.

I set all of the current limit potentiometers to a reference voltage of 1.3 volts which yields a current limit of 1.625 amps per phase which with the NEMA 23 motors yields a current of 58 percent of maximum for those motors.

The default setting from Inventables was approximately 1.0 volt which yields a current limit of 1.25 amps per phase or about 45 percent of maximum for the NEMA 23s.

Then I ran through the Easel Setup procedure and almost everything checked out first time.

The one exception was the homing switch test.

When I ran the homing switch test the Z axis moved down (away from the homing switch) about 0.1 inch and then the test completed and said it passed.

No axis was even remotely near the homing switches.

So, out comes the multi-meter. Measuring at the pins on the gShield each homing switch was at nominally 5 volts with the machine at rest each axis away from the homing switch. I manually tripped each switch in turn and they all went to nominally 0 volts when activated.

So the homing switches worked, and the gShield received a voltage change when the switches were activated, but the Easel test failed (even though it said it passed).

So, has anyone had the Easel test do the right thing? Move each axis to the homing switch and stop.

The few times I’ve tried ‘homing’ my machine, things went awry and I’ve not been game (or had the need) to try it again since. Having said that, I’ve found that the subjects of ‘homing’ and ‘limit switches’ are pretty popular, yet rather unsatisfying threads on the forum.

Not sure where you’re at with your build Larry, but I’m planning on fitting true limit switches (not homing switches) to each end of each axis of my machine. I intend to simply wire a bunch of switches into series and work out how to connect them to the controller so that any switch activation will bring things to a stop.

Once I’ve got some limit switches in place, I’ll make some more efforts towards using the homing switches. I’m just keen on avoiding the need to always have one hand hovering over the power switch all the time; I’m pretty sure the number of times I can crash my machine without breaking something, is not infinite.

Any suggestions from anyone on how to wire these switches into the controller would be appreciated.


Hi, David.

My machine is complete. I’m working on startup software issues at the moment.

Wiring true limit switches is not much of a problem. There are several ways to do it.

If you don’t have your switches yet I can give you some Mouser part numbers for the switches and crimp connectors that I bought. (I bought the “limit switch” kit from Inventables but I also bought other switches for the time that I convert my machine to true limit switches).

Thanks Larry - I’ve already got a bunch of limit switches (not sure if they’re NC or NO now I think about it), but I’m just trying to think of a way of setting things up.

I’m sure I can set things up to simply interrupt the power, but I’d prefer something a little more elegant…

And I assume they’d need to be normally closed in order to break a circuit - trying a make a circuit doesn’t seem very reliable.

You can use the gShield to do the work for you. If you wire the switches up appropriately you can just use the standard connections to the gShield.

Depending on how you wire it you will also have to make some configuration changes to Grbl.

If you are not in a hurry I can come up with something that would work for you, but I’m extremely busy right now.

What’s your time frame?