Laser Control not working?

I just finished my laser install. I tried to minimize the amount of things on the X-Carriage so did a slightly different setup. I also, similar to the video on the JTech site, installed a DPDT switch so can swap the PWM between the laser and spindle. Left GRBL as-is for now. That said, I’m either missing a step or have the wiring off.

The first time I powered on the laser, I did press the button on the laser after turning the key and power switch and the laser came on at full intensity. So I switched the driver power switch off.

I tried sending M03 S1000 with UGS with my DPDT center-off switch set to the LASER side, and nothing happens. When the laser driver power switch is on, the laser stays on.

Is there a step I’m missing to get these commands to control the laser, or is there something in my DPDT switch setup I’m missing?

Attached photos for clarification and display

Try pushing the red button on the laser board when you have power applied its a reset

1 Like

Do you have the Mode Selector Switch set to CW Mode or Input Control Mode. If the switch is set to CW Mode, it will come on at full power.


completely misread what that switch was, thanks for the clarification! Required both actions, pressing the button and flipping the switch. It will now turn on/off with M03/05.