Laser Etch profiles

I’m trying to use JTech Photonics’ Laser Etch with a JTech 2.8W laser mounted on an X-Carve running JTech’s 0.9g GRBL. Once the gcode file is created in Laser Etch I’m using PicSender to send it to the laser mounted on the X-Carve. I’m not getting good laser control (e.g. not turning on/off properly) and I’m wondering about the “Laser Command” settings in Laser Etch. Can anyone provide some guidance on optimum values and their format??? Thanks in advance for any help!



I m gonna follow this because I have the same problem.
Everything works but not the on and off function.

Grtz Koen

I’m sorry you’re having the same trouble, but I’m glad I’m not the only one. I’m confident someone reading this forum will help and I’ve also contacted JTech for guidance.

1 Like

Stock controller or Xcontroller

For me it’s the stock controller.


Stock controller for me as well.

Well that blows that theory. Xcontroller has a $30 command that controls the PWM pulse

I received help from Jay at JTech Photonics this morning and he determined that the laser off command in the Laser Etch settings needs to be M03 S0 instead of M05. I’ve pasted his reply below. Kudos to Jay for his rapid and expert advice (once again!).

"I think the problem is the M05 code. I changed mine to M03 S0 and it worked fine. Somehow the firmware maybe can’t turn off the laser fast enough or something… I’ll have to look into this as it is the first time I have seen it.

I also noticed that you are using the G0 for laser off moves. Do not check that box. It should always be G1 for all moves with GRBL firmware. The “pause” time also is in seconds so you might want to change that to 5 instead of 5000. We are fixing this in the next version."

1 Like

Same problem, but I have the xcontroller. I looked at the GRBL in Picsender and all of the lines start with$. I’m new to this. Do I change the actual GRBL in Picsender editor or do I have to change this in every Gcode I generate. I’m a little confused but almost there.

I don’t know if this will help, but I’ve pasted below the beginning statements from a Gcode file I’m using to etch stamping rubber. The Gcode was created in Laser Etch. You’ll see the first several lines are remark statements starting with a ‘;’. The Gcode statements controlling the X-Carve-Laser follow. None of them start with a ‘$’. This may be different for the X-Controller so I’ll let someone with knowledge of that comment.

;Black and White Bitmap
;Original File: db logo - negative.bmp
;5/11/2016 at 9:40:20 AM
;LaserEtch v1.2.0.7
;Base unit: mm
; Pixel Resolution: 0.045mm
;Using Full Pixel Height
;Laser Off Command: M03 S0
;Laser Print Command: M03 S150
;Laser Low Power Command: M03 S0
;Laser Cut Power Command: M03 S150
;Laser Off Speed: 500 mm/min
;Laser On Speed: 500 mm/min
;Laser Cut Speed: 500 mm/min
;Laser Z-Axis Speed: 200 mm/min
;Using full raster

;Using Precision Print Mode

M03 S0 ;Laser Off
G90 ;Absolute Positioning
G21 ;Set to mm

G1 F500 ;Set Laser Off speed

M03 S150
G1 X0.045 Y0 F500
G1 X0.09 Y0 F500
G1 X0.135 Y0 F500
G1 X0.18 Y0 F500
G1 X0.225 Y0 F500
G1 X0.27 Y0 F500
G1 X0.315 Y0 F500
G1 X0.36 Y0 F500
G1 X0.405 Y0 F500
G1 X0.45 Y0 F500
G1 X0.495 Y0 F500
G1 X0.54 Y0 F500
G1 X0.585 Y0 F500
G1 X0.63 Y0 F500
G1 X0.675 Y0 F500
G1 X0.72 Y0 F500

Hello All,

I am having some issues with the laser etch profiles. I modified the profile to have the correct speeds, and on/off. Reading the generated gcode it shows that the laser should be operating at full power M03 S255 however when I run at the same speed of 15 im/min that I used in my testing of picsender last night the laser activates, in low power mode, traces the boundary box, and then starts its path but seems that the laser is still on low power mode. I tried laying a piece of cardboard just to see if it would get into the top layer and it does not.I even slowed the print speed down to 5 in/min with the same results.

Any ideas?

Thank you,


Switch to Laser Mode in PicSender. In Spindle Mode the $30= rpm max (PWM) grbl setting is 12000 and a S255 command will be very low laser power.

1 Like

Hello again Jeff,

This was while I was in laser mode. I just happened to take the screen shot of the setting after rehoming and switching back to spindle mode to control the Z axis.

I just tried it again to be sure.


The Travel Per Pixel setting seems high, but we don’t use Laser Etch, so I don’t know how that effects the gcode and movements. I do know the Start Comment for grbl is ( and the End Comment is ) :slight_smile:

1 Like


It is almost like the laser is not getting enough power. I am using the Demo of Picengrave 5 and loaded and resized an image. I found that it was going to be smaller than I had thought, so I quit the engraving and loaded the original side. I then again exported the gcode and ran it. Durring the 1st small image it engraved a boundary box, and started the image. On the 2nd full size image it ran the direction of the boundary box, but the laser again while on did not engrave just like the laser etch issue.

I then compared the gcode side to side and the laser commands are the same when it is making the passes?




Of course after I placed my back probe pins into the laser input power and tried it on picengrave again it is working now, at least for picengrave. This being said I will have to see what happens and report back.

Thanks again Jeff.


1 Like

First look at page 7 in the Tutorial on how to resize your image in the editor for engraving. If your image is a black & white logo, you need to save it after resizing and open it again to dither it 1bit B&W so there will be only two power levels S0 & S255 on/off. I notice in your gcode there are power levels in between, so that means there are gray shades.

The focusing of the laser is very important for it to burn properly. Are you sure you have that correct?

1 Like


I am very confused now. Sorry for all the questions, I am typically great with software. I just purchased the Picsender, and Picengrave Pro 5 + Laser. I wanted to try doing just my logo, so I loaded the file, clicked edit and resized from 3600px, to 600px. When I save the file it shows at the correct 600x600px, but when I then go to open the resized picture it seems that it did not resize the picture, but instead cropped the picture? Please see my screen shots.

I do believe that the laser is focused correctly. I followed the steps from J-Tech website.




OK, start over Devin.

Did you start out with a transparent png image? If so, save it in AI as a jpg or bmp, then open it in the editor. Select Auto in the Adjust Image Size. Input a .006 for the Pixel Resolution and adjust the Pixel Width or Height until it shows the the size you want it engraved. Save as a bmp or jpg. Reopen the file in the editor and select the Threshold Dithering Algorithm. Save it again. It will only save as a bmp.

After opening it in the main screen, use the Analog/PWM engraving profile. Set the Pixel Resolution at .006 (same as in the editor). Select the Skip White Bkgnd, Left 45 Engraving Angle and select the Feed Rate Change and set at 25%. Set the feedrate at 100? and a Max 3rd Axis Depth of 255 and Min 3rd Axis Depth of 0. Make sure you set the 3rd Axis Letter as S. Select Spindle on/off & set the Start and End Comments ( & ). Generate the gcode and give it a try.



Here is what I was able to get using the dithered image at 2.592" squared.

I am not sure if this looks acceptable or if it is able to get cleaned up more?

Thanks for all the help!!!