Limit switch causing connection fail

Hi. I switched over to the x-controller today but having strange problems. Assembled to the letter, ran easel and all the axes worked fine. I start the homing sequence but nudges a little than stops. Tried everything and rechecked all wiring and assembly but nothing. Tried skipping the homing setup and when trying homing before carving, error message saying something blocked. Than I notice that whenever I test the z limit switch, I lose connection to the machine all together. When switch not pressed it connects again. The y and x switches don’t have this problem. It’s been fine with original controller and it’s such a strange problem I can’t find a solution anywhere. Please HELP!!!

Hi @AnthonyKim - if you haven’t already, please reach out to our Customer Success team! You can either call or email them. Here’s their information.

1 Like

Sounds like a short. Check the connections of that switch.

Tried new switch, new wires but still same connection loss. Could it be a x controller board defect? Cuz when I plugged in the x or y wires into the z I get the same result. So I’m thinking defective z limit connection on x controller board

Called inventables and they agreed likely power board defect so they’re gonna send out a new one. Hopefully it works. I’ll post an update after getting it.