Limit switch not engaging

I could use some assistance please. I noticed that my limit switches are not stopping movement in any of the axis directions whenever the switch is engaged. I have checked the switches and they all have +5vdc sitting at the switch and they all drop to 0vdc whenever actuated. Does the manual movement whenever setting up to carve override the switches? Any help is appreciated.


@JamesMurray did you try the easel setup?

@Zach_Kaplan that was the trick! Thanks for the help!


1 Like

I have now run through the easel set up three times trying to get the homing/limit switches to work. I can’t seem to get past the Z-axis test to see if the others will actually work or not. I have now replaced three switches. I have about 7 more tests (Switches remaining) to go. I will keep reading through the various posts about others having the same issue to see if I can make sense of this. It seems like I have the wiring matched what was in the guidance for the set up and even matches others who have made comments.

I remember for the limit switches (and for the rest of the electronics in general), I had difficulty getting all of the common ground wires securely connected to the common terminal. Is there any chance they’ve become loose there?

Also, do you have access to a multimeter? You could use the continuity check to make sure the switch is closing, although if you’re already on your fourth one, it seems unlikely that it’s a mechanical problem.

Could you post pictures of the switch, and the wiring at the power supply/grbl shield?

PeterJames- thanks for the feedback. I believe there could be a problem with the common ground. I was concerned about that before, especially with five wires heading to the same small hole. I connected the wires in a group with a wire nut and sent a single black wire into the ground. As I was checking to see if they were all still connected well, now I get a constant spindle on. I moved the spindle power switch to ‘off’ and ‘logic’ with no response. The spindle just keeps running! I hit the reset button on the gshield and the arduino with no change (after cycling the power on and off during the reset). I went ahead and took the electronics back to ground zero and reconnected everything- still have a constant ‘on’ spindle. I went through the Easel setup and tried to see if I could control the spindle that way- no luck. Thoughts?

Just came across this thread: Spindle Will Not Turn Off, I think it might be relevant to your problem


I had the exact same issue. I owe a guy some donuts for helping me find the problem. I’ll bet yours is the same. On the circuit board that has the three position switch there is a MOSFET. It is an electronic switch. It is probably fried. If you have a multimeter you can check it. Let me know if so. I can post a picture of where to check for a short circuit.

When everyone stop calling those switches comes with the kit as “Limit Switch” most of the problems will be disappeared. Those are “Homing switch”. It is possible to install Limit Switch, which sends signal to electronics even moving axises manually on the keyboard keys. That’s called limit switch. Mostly new users are hitting keyboard long time, Arduino getting one long movement command and smashing to sides or breaking Z homing switch. Normally we have HOMING SWITCH comes with kit, only works for finding home position. Correct me if I’m wrong Peter.

@AlanDavis I think this confusion as you say is coming from the X-Carve configuration tool. They are called a “Limit Switch” instead of a “Homing Switch” when ordering the X-Carve. I assumed as much from the start before doing any research, so I don’t think that assumption will change until the order page is changed.

I have been doing a lot of reading on them over the last day trying to find the best way to add some limit switches as far as the shielded wire to use to making them normally closed and filtering circuits… Got a lot of bookmarks ready for when my X-Carve comes to get it all figured out.

Here is a little explanation to clear what that means.

Has anyone implemented true limit switches with the X-carve yet?

I have the X carve together everything works but the home/limit switches. I open Easel and try to do the homing set up and moves ½ down on the Z axis and stopts there. Does nothing else and the screens stays still like is doing the set up.

Julio, I am having the exact same problem. Did you figure it out?

1 Like

Yes I did. I contact inventables and they told me this: reset the firmware by sending the following command from the console in Easel’s Machine Inspector (Machine Menu > Advanced > Machine Inspector):


After that mine didnt work still so they told me to open the Xcontroller and unplug and plug again the Ribbon wires to make sure you have a good conection. After that I was good

Thank you very much! I’ll give that a try. Was starting to lose hope.

It worked for a minute, fixed the loading issue. Now y goes in opposite direction.

Do Y move correctly if you try to jog it back and forth?

  • If yes, reverse direction. Either through setup where you test/confirm travel, or by changing GRBL parameter $3 or swapping the “polarity” around by flipping the green/black wire on the controller side.
  • If no and direction appear to be random you have a poor connection on one of the four stepper wires.

I am so sorry. I just now noticed that I had a notification for this on my profile.

Yes, I figured it out. I had the wiring backwards. Black and green I believe it was on one of the motors. Felt dumb after sitting there for six hours trying to figure it out.

Glad you are up & running :slight_smile: