Limit switches at all times!

Does anyone know if Inventables is working toward writing the software of easel to have limit switches work at ALL TIMES??? I did a job a little taller than I normally do and after using my probe it went up too high and broke a limit switch. I find this very frustrating that these switches don’t work at all times!. It would be a lot more comforting, knowing that your machine will stop and not grind belts or break switches. I know the error is on me here… but if they upgrade easel, it would be a nice change to have.

Thanks,
Casey

That function is already there, you just need to turn it on.

If you use homing and soft limits then you won’t crash your machine. ($22 = 1 and $20=1).

2 Likes

I have turned on my homing limit switches. However they don’t work at all times. only when I am homing the machine. How would I go about making them work at all times?

Do some searches for soft limits… that’ll prevent you from going too far in x, y, and z.

Once you start using soft limits you’ll never look back.

Homing is separate from “hard limits”. If you just have your switches set up for homing they will do nothing if triggered when you are jogging or while cutting.

If you want them to act as limit switches as well you have to enable that ($21=1) instead of ($21=0)
Like Larry said above though I use homing and “soft limits”, which stops your machine crashing. You just need to enable them and set your max travel distances.

Thank you guys for the help. How do you change the soft limits? Under machine inspector?

Yes. I think it is Machine Inspector -> Advanced

$22=1 turns homing on
$20=1 turns soft limits on

$130, $131, and $132 sets the max travel distance for X , Y, and Z axis

This is what I use for my 500mm X-carve

$130=290.000 (x max travel, mm)
$131=290.000 (y max travel, mm)
$132=88.000 (z max travel, mm)

1 Like

Okay. I think i figured out how to change the code. I can move the machine around until… I tried to see if they worked by going back to far. it did not allow it but then it locks it up and it wont let me move in a direction that does work… Is this how soft limits are supposed to work?

I have to restart a new browser window before it will release it.

You have to clear the soft limit alarm. I don’t know how Easel does it.

In UGCS or other sender programs you can do a soft reset to clear the alarm.

Thank you all for your help. I appreciate it!!!

1 Like

PhilJohnson what program are you designing your projects in to generate your gcode for UGCS?

Yes, you do have to home if homing is active.

1 Like