Limit switches DO NOT work

limit switches do not work on X,Y or Z

Can you give a bit more detail?

Hello John,
Assuming that you, like me, are assembling your new X-Carve, I might have a suggestion worth checking. I just finished putting mine together last weekend and I had trouble with the homing too. After a bit of double checking, I realized I had connected the black wire to the wrong end of the limit switch. I also had to move the X & Y stops further from the edge to get them to engage before the dust shoe mounts hit the corner.

I hope this helps.

Thanks
Jason

THANKS. im going to check the connections…

John, when you say not working do you mean your machine won’t home or the switches don’t prevent the machine from crashing into the ends?

Note the switches/wiring that come with the machine are homing switches only, not actual limit switches. After you home the machine, these switches don’t do anything.

1 Like

i didnt realize that…i thought they limited the movement so it would STOP

1 Like

The out of the box kit/instructions don’t do this. Although it can be done. The easiest way most folks take care of this is with homing switches and set up “soft limits”. Do some searching on how to set these up. There are guides already out there.

They do…but only during the “homing” sequence.

Just to muddy the water a bit!

The homing switches can also act as “Hard Limits” if you have $21 set to 1 …

Grbl - Hard Limits

By default, this is not set on X-Carves though. You would really want to have one on either end of each axis to use “Hard Limits” correctly with each pair wired in series.

That being said, a lot of people enable “Soft Limits” which works pretty well.

{:0)

Brandon Parker

Thanks for all the feedback…John