Inventables Community Forum

Lithos with MeshCAM

Needing some help with doing lithophanes, I’m familiar with the process but using MeshCAM and having to deal with the Smart Clamp is giving me issues. The tool wants to initially cut into the smart clamp before finding the material I’ve moved away from the ‘zero’ point.

Has anyone successfully done this? Thanks in advance!

Did you import the gcode into Easel?

Yes, and the bit after touching the homing button it crashed into the smart clamp. There’s a travel toolpath that slightly dips down as the first few lines of gcode. I don’t want to have to edit this every time I make a litho. Any ideas on why this is or how I could correct this in MeshCAM?

I believe it’s a program zeroing issue but I’ve triple checked all my settings.

Can you share the gcode?

test maureen.nc (299.6 KB)

Here’s the test file I was using and the same file the crashed into my smart clamp. If you preview it in Easel or in Camotics you can see it lowers itself ever so slightly on the z axis before traveling away from program zero.

Is the machine set up as a Carvey in Easel?
I see the first move as G0X2.6528Y5.3642 when using the Carvey.
Non-Carvey includes the Meshcam code, G0X0.0000Y0.0000Z0.1000, which would be a retract to safe height on a machine without a “Smart” clamp in the way.

Not seeing that.

So, Here’s what’s happening. First and third photo are from the gcode I sent you, the middle photo is from a different litho I did using MeshCAM and it came out fine on the Carvey.

I did the same steps to make another litho and for some reason it crashes into the smart clamp now (see first pic). I figured it has to be an issue with setting my program zero in the tab on MeshCAM but I’ve tried altering every possible input field and when I generate the toolpath it gives me this (photo 1 and 3). I just want it to look like photo 2, but I also shouldn’t have to open the gcode file and delete the affected line every time.

Thoughts? Thanks for your responses so far! Appreciate it!

07 PM

And just to clarify, if you look at the very first travel path away from the smart clamp in photo 2, that’s what I need continuously. I have a bounding box in MeshCAM around the litho so I have no idea why it wants to take that random trip directly for my smart clamp.

Here’s what I get with your file:

Haha, this is frustrating. So you think it’s a setting I’m using in Easel? Just trying to pin point the issue.

Ahhhhh, so I have to change it to Carvey in my machine setting PRIOR to uploading the gcode! Brilliant!

Thanks a ton!!!

1 Like