Lock/Unlock Motors Buttons don't work

I am trying to do a 2 bit project. When I go to change to the second bit I can’t lock the stepper motors. The unlock button is green and the lock button is red. When I click on the lock button nothing changes. Thinking maybe there was no visual indication, I tried changing the bit and jogged the gantry. Any help would be greatly appreciated.

research this, If I remember correctly I also had to change one of the dip switches, HOPEFULLY Neal or Harold can elaborate. I cant find the thread I used to set mine.


In Easel, I seem to recall that the Lock/Unlock function is one that only works on a Pro Day. (just like being able to change the raster fill).

I’m not sure what “$1=255” means. Sorry for my ignorance.

Drew I have a Pro subscription, which is why I posted this in the Pro forum. Thanks just the same.

@NeilFerreri1 Neal can you elaborate, I cant remember exactly but do you also have to change any of the switches on the control board?? I believe I read at one time you made a change there so they were full power.

The buttons never worked for me, there are a lot of threads on this in the forum.

You can set the Xcarve in machine inspector so it will apply torque the the motors when the machine is idle.This way you can change bits and nothing will move while you are doing it

Machine inspector

Type in $$ and press Enter, a list with the different GRBL $ values will show. Check $1, if anything other than 255 change it by:
Type $1=255 and press Enter.
Power Xcontroller OFF->ON and check the listing once more to confirm new value.

Yes, Dip switch #4 for each axis. OFF = Idle Current mode is OFF, stepper get full power all the time (governed by GRBL $1)

$1 set the time in milliseconds the stepper is energized when idle, before it get no power at all - only holding torque available. So $1 can range from 1-254ms but value 255 = Full power all the time.

What @HaldorLonningdal said.

Thank you all very much. Yesterday afternoon I called Inventables. I was walked thru changing the setting to 255. She told me to put both axis dipswitches to OFF though. Hmmmmm.

That’s what @HaldorLonningdal said too. That disables the idle torque reduction, so your motors hold at full torque even when idle.

1 Like

Thanks Neil.


Thanks @HaldorLonningdal and @NeilFerreri1 for the assist!

I couldn’t find the actual thread I worked from, I may have done it from Design by Phil’s Website, JUST couldn’t find were I got my instructions

1 Like