Machine not connecting

Two days ago everything worked. Tonight no connection.

Windows 10 tablet

I’ve rebooted. I’ve reloaded Easel drivers. I changed cables. I changed ports. I installed Ardunio IDE (and it appears to connect).

I tried USGS to just move the gantry around but got “grbl hasn’t finished loading”.

I’ve looked through the support and tried basically everything.

At my wits end. Any ideas?

How does it appear to connect?

This might sound odd but try unplugging the usb cable from your computor then turn the xcontoller off and turn it back on then load your program and plug it back in and see if it connects.

1 Like

What @WayneHall said and a restart of PC will help.

1 Like

I had this dogging me for awhile and found an instance of Chrome running in the background with Easel open.

Now, I seem to connect best when I turn on the x controller and then open Chrome and login to Easel.

the program recognized the com port and arduino. i don’t know anything about using the ardunio interface other than looking to see if it connected.


I removed Easelocal and resarted. I then reinstalled Easel local using 3.12 (the first one i installed when i got the x-carve)

In USGS when I click firmware settings (the controller has been on for several minutes and i exited easel before opening USGS)

Does COM1 only appear when you connect your USB cable?

No, it is there all the time.
The tablet only has 1 USB.
When I connect my phone instead it shows up down in the USB area at the bottom of the manager.
Currently when the controller is connected there isn’t any other USB thing listed.
I never looked to see where the x-controller was or looked like while it was working.

It doesn’t give the audible tone when the controller is first plugged in anymore.

That’s not your controller. (COM1)
Have you unplugged USB, powered down X-Controller, Restarted computer?

yes about a dozen times was the first thing i tried with different orders of boot back up
my computer doesn’t seem to recognize the controller anymore. problem with computer or controller?
sometimes my samsung phone is not recognized on other pcs so i don’t know where to point the blame

Controller powering on ok?

Can you connect directly to the USB on the controller PCB?

When did you lose your communication…I saw the other thread where you were trying to flash firmware.

Yeah, I’ve tried direct connection to the x-controller board too (just too off the front cover and top and connected it that way and no change.

The firmware update went nowhere because i am not really connected.

I lost connection when I first turned it on today at 4:00. I needed to get a keychain engraved and into the mail… obviously it didn’t happen. I tried the resets and pluging in order and then more desperate measures of uninstalling the software and reinstalling…

Got a laptop you can try? (Hopefully will connect)
Anything else USB you can plug in to your tablet? To test USB.

And again, does the X-controller power on?

laptop did not recognize any new hardware when controller plugged in (both off or on before plugging)

I can plug my samsung phone or a mouse into the tablet USB and both work.

x controller powers on emergency button off the switch so on green light at front

earlier tonight a disconnected all cables and plugged all back in.

right now the controller does not have the motors and things connected since I brought just the controller box into the house from the garage

since it is now Wed morning here, going to bed and calling customer service later

Next thing I’d do is start probing the thing with a multimeter, but hopefully CS will be of more help.
Last would be to start reflashing firmware through the ISP pins.
Good luck…update the thread with any new details.

Given the lack of showing up in the device manger on multiple computers and bypassing the front panel usb, they are sending a new board. So no robot cutting for me for a bit.