Machine randomly plunging bit all the way through

Hey everyone,
So up until a few days ago my machine has been running well with the exception of losing steps on Z, but I was able to sand out the imperfections
All of a sudden now with every project I have put on it the machine will randomly plunge the bit all the way through the piece until it bottoms out on the collet.
I’ve tried 2 projects, one a simple pocket sign once and the other a 3d roughing profile twice, both were made in v-carve pro
With the 3d rough cut it happened at around 50% the first time and 7% the second time. Not sure what to do here??
I’ve checked all the electrical connections and they’re all tight, POTs are all adjusted to spec
Machine has the new motion controller

Here’s a pic of the router right after it happened as well as the CRV file :frowning:
Just before it bottomed out the z lifted and router moved to a new position, it should have plunged to the same depth as before and continued cutting

702-2, 3D Owl Clock w Odyssey-2.crv (9.3 MB)

You are losing steps badly on the Z axis. Check to be sure the set screws in the Z belt pulleys are in tight and the pulley is not slipping. Also check to be sure you have the voltage for the Z motor set correctly.

All the belts, screws etc are good and tight, the Z has no problem moving and it’s nice and smooth
Do you know where to place test leads to measure the current?
I can adjust the POTs if necessary, just not sure where to test

Easel PP in V-Carve, using Easel web based in Chrome to send to the machine

Search the forum. There is a procedure to set the voltage without using a multimeter. It gives better results since it set the voltage to exactly what your motors need.

The slipping pulley allows the tool to move down but can not pull it back up so it just continues to plunge deeper.

Dollars to donuts it is mechanical or motor voltage.

1 Like

I sat and watched it the third time, I didn’t see any slippage. Seemed to me like the machine was being instructed to plunge IMHO
The Z moved up as it should have then just plunged all the way in

I checked all screws after the second failure, didn’t use loctite, but they’re still good and tight :slight_smile:
It should have plunged about 1/8" then stopped but it just kept on going

Honestly, I’m not sure how to check the g code
Do you have a link to a tutorial?

I know I can open the code in notepad but not sure what to do with the info.
I’ll give UGS a try tomorrow and see if I notice anything.

Thanks :slight_smile:

I had a Gshield on my earlier machine that would randomly command a full plunge. It proved to be a faulty board that Inventables replaced quickly with no drama. Dont rule out hardware failure on this one as it is not unprecedented.

I had an issue that on the initial raise to 20mm above origin that the z axis would max out but the software thought it was higher than it was. So when it came down to a position it thought was 2mm into the material it was actually all the way through and into the waste board. Since this I have swapped out my z axis for one with more range.

Two words: BLUE LOCTITE!

1 Like

So I’ve loosened and re-tightened with loctite all the bolts that work the Z axis as well as upgraded the easel driver.
I did test the g-code in two previewers, one online and another locally installed on the computer and neither indicated that the bit would cut deeper than expected from the v-carve preview. I’ll run a job later and update.
To clarify, the bits are passing through the .72" stock and into the waste board until the collet physically contacts the stock
Thanks all for the replies

Verify that Home Position Z parameter in Toolpath setup of Vcarve is not greater than distance between position 0,0,0 and Z limit switch. Had that issue before and machine would plunge bit into project.

Is this what you’re referring to?

I’ve let it go up to 7% on the same carve as before which is the same place it failed last time and so far it hasn’t had any issues, there are no lost steps anywhere. I need to get to bed now, I paused the machine and will start again tomorrow

Running the job now, 40% and still OK
I did notice that Z was loosing steps on the first “layer” of the 3d rough, about 1/32" so I paused the job and adjusted the pot up about 1/16 turn and so far it’s mostly done the second layer and no lost steps. Fingers crossed!

That’s impressive Phil :slight_smile:

66% now and OK. I still think this had its roots in software, should have done a test between reseating the bolts and updating the driver. Oh well, hopefully I’ll have good results to report once the cut is finished

1 Like

I had a similar issue with my diy cnc, Z-axis would on occasion go down uncommanded.

My issue was mainly underpowered Z-axis (Nema17) with overweight spindle (MakitaRT701).
ACME T8 rod and Delrin block. Unpowered the Z would drop from its own weight as the friction is the rod/block was so low and holding torque of the Nema17 (49oz/in) to weak. Supporting it with dual springs to take some of the weight off helped - but ultimately an upgrade to Nema23 (269oz/in) solved my issue. Its holding torque is quite sufficient to carry the total mass of the spindle arrangement. My old Nema17 was running mighty hot btw, water sizzled off of the motor case :wink:

In my case Z would suddenly drop because of its lack of holding power and increased pull from the material as I carved. FWIW :slight_smile:

That may have had something to do with it, I have the NEMA 23’s and when I upped the power a bit it stopped loosing steps.
I did get the job to 100% without issue this morning so I’ll be rerunning the job later on the finish piece. Hopefully the same will be true when I load up the expensive stuff :relaxed: