Machine stops responding after a minute or two

Hope someone can come up with a suggestion on my issue as it’s driving me nuts…

I start a job and everything works fine, after a minute or so of cutting however, the machine stops responding. The timer in UGS keeps ticking away, but there doesn’t appear to be any more info transfer between UGS and the X Carve - the usual command sent and “ok” responses in the UGS window stop.

I’ve tried the following:

I’ve created a new GCode file in case the one I was trying was somehow corrupted or contained some random weird command.
I’ve downloaded and installed the latest version of Java
I’ve downloaded and installed the latest stable version of UGS
I’ve rebooted my machine & disconnected and reconnected the USB cable several times

The last few commands don’t appear to be “done” - is this indicative of anything? (I’ve never looked at this window before)

Note that the last command appears to have no “ok” below it. Does this mean my GRBL card is faulty? The “cancelling file transfer” only appeared because I tried a “Soft Reset”

If you have soft limits enabled you must run a homing cycle. It is odd that the Y Machine Position shows a positive number and the X Machine Position shows a negative number. They should both be positive or both negative, depending on the settings in config.h

@DavidWestley are you using soft limits?

Doesn’t like you.:smiley:

I run Windows 7 (UGCS version 1.0.9), so far, no problems.

I found version 1.0.9 too problematic, once I switched to the nightly build all of my issues with UGS went away.

1 Like

Thanks folks. Tried a heap of different things (I’m running UGS on an old Mac Mini) and after getting stumped, I did what an old tech suggested - “Don’t do anything until you’ve checked all cables, connections and cards”. Investigation showed that my USB ‘extension’ cable, had been damaged after being too long underfoot. I replaced this and the problem seems to have disappeared.

The USB cable still appeared OK, but some of the outer woven sheathing wires had been damaged. I don’t know whether this wiring is simply a shield or whether it’s part of the wiring connection, but whatever it does, having about 80% of it broken seems to upset my machine sufficiently that it stops and refuses to accept all further commands.

Given that the previous night, the brushes on my DeWalt had finally wore away, and the fact that I couldn’t find any replacements and so had to make a set, my X Carving has been very labour intensive.

Many thanks for all your responses. Once again I’m amazed at how helpful everyone is in assisting others.

Regards, David.

1 Like

@DavidWestley
It was the Shield in the cable. If the cable was run not next to any other wire (data or power) or any thing with electromagnetic radiation and/or shorter it may have still worked. The Wiki about Shielded cable https://en.wikipedia.org/wiki/Shielded_cable

Years ago I was flown 2000 miles to fix a downed computer system network. After a hour found that is was damaged shield on a long run of network cable, I said call a cabling company we don’t do that and I was back to the airport.

All suggestions appear to indicate a “software” problem. If it helps my machine has VERY unusually failed to play nicely, luckily at start up, for two reasons - G-shield vibrated off its location on the Arduino and so no expected light display at the board (refitted with a little more pressure) and no 24 volt supply which turned out to be a poor kettle lead joint at the power supply (gently twisted pins in socket slightly to cure). Worth checking?