Machine suddenly does not connect

Hello everyone.
I just powered on my xcarve and activated my free pro day.
But somehow, suddenly Easel could not find the machine anymore. It was always working like this.

There was literally NOTHING changed. I have a notebook that is only there to run easel and nothing more. So I just tried to find the reason, but now I am totally out of ideas.

Windows 10 (always updated) + Arduino Grbl Machine

Here is what I tried for the last 1,5 hours…

  • Install FTDI Drivers
  • Reinstall Easel (like 20 times)
  • Remove/Uninstall Com Device
  • Install Arduino / Universal GCode Sender
  • Reflash arduino with latest GRBL Version
  • Different Browsers (Chrome + Edge + Firefox)
  • Disabled Windows 10 Security
  • Reboot between pretty much every step
  • Manually switched the Com-Port (tried 1-5)
  • Different USB cables

Strange thing is that the controller was always detected.
I was always able to connect to it with UGS and see it is setup correctly.

Any more ideas what I can try?


Hey @MerlinKonert - if you’re still having issues, reach out to our Customer Success team directly to see if they can help! or call (312) 775-7009.

Thank you.
After countless hours I stumbled upon this thread:


to my localhost file finally helped.
I got no idea where this does come from as I did not change anything