Machine won't Jog or Home After hitting E-Stop

Hey guys I was trying out this dual bit feature in Easel and was using a piece of board that was pretty much exactly the size of my cut, it landed up going past the piece so I hit the E-STOP. Once I reset the estop and tried to jog the Z up to remove the piece it will not jog any axis and will not jog home it stays on please wait. I reset the estop and hit again and reset, clicked the play button reset the xcontroller and easel and still nothing. Any Ideas?

Opened the front face to see if maybe one of the connections came loose they are both still good. Getting g kind of scared here

Yes I tried that. Still nothing. Is there some sort of reset button in the xcontrollers?

Ya I don’t see no Reset button

Have you tried rebooting the PC? Pressing the ESTOP turns off the Xcontroller but doesn’t clear the serial port resources on the computer.

Yes Reset PC, Disonnected serial plug and turned xcontroller off. I am starting to think that the E-Stop is actually a self destruct button.

1 Like

Did Inventables replace it? This is only my 3rd time using the E-STOP and now all of a sudden I have permanently lost connection to my Xcontroller. I can click carve but when I click to home it it is stuck on please wait and if I try to jog, nothing happens.

Go to Machine -> Advanced -> Machine Inspector then check/uncheck the box saying show/hide status or similar and see what that shows in the console window.

I’m assuming it is saying status alarm because of the estop, wonder how to unstick it from being stuck on alarm

I don’t think the probe status should be green. That’s probably why it’s in an alarm state. If all else fails, disconnect your probe.

It’s not connected.

Type $X in the console and press Enter

HMMM… Looks like it’s working now. not sure if it was the software being glitchy or the estop being stuck a bit or something. everything seems to be in working order. I guess it just took a few minutes of leaving it on to change its state.


Off topic –

Since you home your machine, do yourself a favor and turn soft limits on ($20=1).

– back on topic.

1 Like

what does that do?

It prevents your machine from moving outside the work area so that you don’t crash into the homing switches or the rails.

It causes grbl to examine each g-code command to determine if the request is out of bounds.

When homed the allowable work area is restricted to the cube bounded by Machine X0,Y0, Z0 and the Machine values in the $130,$131, and $132 grbl parameters.

Did you hear the fan?

I hit my E stop once and when I released it it didn’t release all the way so it was still in the “off” position even though I thought I heard it click into the “on” position.

I fixed it by hitting the Estop again and releasing it again. Then all the power came back.