Maker M2 - donut

I’m working on a Maker M2. Things are going pretty good - almost completely calibrated (?) except,maybe the Z axis. Anyway, I’m trying to cut a simple donut - 10" diameter inside, 16" diameter outside. Here’s the file in Easel:

For some reason, the M2 cuts the inside circle but then throws an error and does not cut the outside circle:
“soft limit alarm. G-code travel exceeds machine travel. Machine position retained.”

That error sounds like the G-code wants to send the sled off of the panel but that’s not gonna happen - it’s cutting in the middle of a 4’x 8’ sheet!


did you home the cnc first? has the grbl settings for $130,$131,$132 been set correctly?

1 Like

The MakerHub software allows you to set the “work home,” so yes, I did home it first. I don’t know about grbl settings - what are they?

1 Like

i’m talking about homing the machine, setting machine position to 0,0,0. not sure if the M2 does this or not. but could be related to the issue if limits are turned on and machine homing is not being performed. If the machine is not setup to perform the homing function than the limits should probably be turned off and this could be the issue/resolution…

Thanks for this Seth. I can send the sled to the machine home (as opposed to the work home).

I did find that, in the Easel file, I had my X and Y settings for the panel size reversed. I ran out of time but I’ll test this today and see if this might be causing the problem.

1 Like