Motor ultra slow after firmware change for laser

I upgraded my xcarve with a Jtech Laser diode. As suggested had to change the grbl firmware for one modified by them since it will generate gcode for the laser based on SXXX and not SXXXX as the standard. 9j. The thing is that after changing the setting to the known working ones as before, motors spin super slow, almost 30s for 5mm.

Any help is appreciated

Check your feed rate? Try F250 in the command line. I suspect you already tried that but it may be the issue. Are you still working with the 9j or are you still using the jtech 9g?
With the 9g, I have the follow grbl settings:
$0=10 (step pulse, usec)

$1=255 (step idle delay, msec)

$2=0 (step port invert mask:00000000)

$3=3 (dir port invert mask:00000011)

$4=0 (step enable invert, bool)

$5=0 (limit pins invert, bool)

$6=0 (probe pin invert, bool)

$10=18 (status report mask:00010010)

$11=0.005 (junction deviation, mm)

$12=0.002 (arc tolerance, mm)

$13=0 (report inches, bool)

$14=1 (auto start, bool)

$20=0 (soft limits, bool)

$21=0 (hard limits, bool)

$22=0 (homing cycle, bool)

$23=3 (homing dir invert mask:00000011)

$24=25.000 (homing feed, mm/min)

$25=750.000 (homing seek, mm/min)

$26=250 (homing debounce, msec)

$27=1.000 (homing pull-off, mm)

$100=40.000 (x, step/mm)

$101=40.000 (y, step/mm)

$102=188.976 (z, step/mm)

$110=8000.000 (x max rate, mm/min)

$111=8000.000 (y max rate, mm/min)

$112=500.000 (z max rate, mm/min)

$120=10000.000 (x accel, mm/sec^2)

$121=10000.000 (y accel, mm/sec^2)

$122=50.000 (z accel, mm/sec^2)

$130=790.000 (x max travel, mm)

$131=790.000 (y max travel, mm)

$132=100.000 (z max travel, mm)

Thanks Jeremy. I got it resolved yesterday after connecting the board to pics ender where it told me that I had no feed Rate. It never crossed my mind since other version were running fine. Don’t know why jtech default was so low