Motors not

Got this 1000mm xcarve used. Was told it worked (and I’m sure it did at some point since there is sawdust in the x-controller enclosure) Seems like a 2015 machine with an x-controller since it has the wire terminals.
Controller lights up and connects, motors make noise like they have power. The power supply is set to 115v, estop is working correctly. Setup easel and it seems responsive (goes through connecting and writing) but when it comes time to move the axis none of the motors move. I have a spare nema23 from a spare project so I wired that up and still no movement.
If facing the back of the controller from left to right the wires are white, red, green, black
While the motors do make a click sound they aren’t locked as I can still move them by hand. I would assume since it was working at some point the wiring would be ok. I checked input voltage to the power supply and have 83v AC between Ground and N and 40v from Ground to Line. DC output voltage is 24v so it seems like the power supply is good.

homing switches are disabled
I tried a new laptop with a new USB cable and redownloaded the FTDI driver. (it doesn’t ask me for the com port but I know its connected when the jog buttons pop up on easel)
I also did a firmware update on the controller which had no issues at all. Rebooted everything and still same. Will not move

Big thanks to Jenna at inventables for helping

I followed this as she suggested:

Updated all that. Removed the drivers, reinstalled the drivers. power cycled the laptop and it would connect but then disconnect after moving once or twice. I’m going to assume this was due to the laptop being on low power. I grabbed my other laptop (did fresh driver install) and now it work and didn’t disconnect.

It did say detected errors communicating with the machine but it quickly went away after trying a new usb cable

It’s on firmware grill 1.1g and easel version 0.3.21


Holy crap!!! Thank you, thank you, thank you for this!

1 Like