Motors not responding during Easel set-up

I am having the same problem as in Motors not responding [Resolved] in which none of the motors respond to inputs from Easel. But I can’t respond there, so here’s a new topic.

  • X-Carve, 1000mm, limit switches, Dewalt 611, and ACME rod.
  • I removed and re-seated my GShield to my Arduino (though the Arduino isn’t screwed down to the enclosure because if I did screw it down, the GShield doesn’t fit in the enclosure).
  • With the power off, I can move the three axes and see the correct lights illuminate on the GShield.
  • I have all but one limit switch attached (I ruined 8 of the 10 crimp connectors trying to get it crimped—what a pain!)
  • All other electrical connections seem OK.
  • Arduino software seems installed properly (Windows 8 sees “Arduino Uno (COM3)”).

Not sure where to go from here. Any help would be appreciated.

I think you couldn’t insert your G-Shield properly. That top part with fan easily closes if you do. Of course you have Arduino connection, but doesn’t mean Arduino reading your G-Shield. Arduino works without it. You have to put some flash light to see G-Shield pins inserting properly to Arduino long female connectors.

If you have your gShield mounted to the Arduino propery, and the USB cable plugged in to power the Arduino, and the 24 volt power supply turned on — you should have a blue LED and three green LEDs lit up on the gShield.

Alan has a good point if you can’t screw the Arduino down in the case and attach the gShield with plenty of room to close the case then something is not mounted correctly.

1 Like

The top part with the fan closes easily regardless—it’s the Arduino-GShield combo that does not fit (in the horizontal direction—not the vertical one) when the Arduino is screwed in. With both outside of the enclosure, I can easily see how they should connect. With both connected and set into the enclosure, I still do not get the motors responding to jog commands within Easel.

With everything plugged in, the only light I see is the blue light on the GShield. I only see the green lights (each next to the black wire from their respective stepper motors) illuminate when I have the power off and I exercise the spindle mount manually.

Since the Arduino isn’t screwed down, can you lift the two connected out of the enclosure and show us a picture of the two connected together?

Something about them not fitting properly (horizontally even) sound like there is a problem with the connection between the two.

The lights powering on when you move the X-Carve manually is power being generated by the stepper motors. This is power feeding back on to your gShield. Try not to do this too much or too fast.

I can see on the picture, Gshield sitting on aluminum at the front. That means pins are not inserted to holes. They’re not engaged.
Suggestion; take both boards out. Snap them outside and connect the USB. See if it works this time. Helps you to determine how those line up to each other.

Yes, the photo above shows the original configuration—with the Arduino screwed down and my attempt at getting the GShield to attach. I had since pulled both out and joined them, setting the assembly back into the enclosure. I pulled it out again to take these photos.

This is the top of the inside of the enclosure now. Arduino is not screwed down. I have a business card beneath the Arduino to prevent errant contact between metal contacts and the threaded risers.

I think I see the problem—some of the vertical pins (IOREF, RESET, GND) on the power side of the board pair were pushed out of their aligner during the mating of the boards and are probably not making contact. I pushed them in manually. I am installing the Arduino software on Linux now to test this (I was booted into Windows before). Edit: I see that there is no Easel for Linux, so I guess I need to boot into Windows.

I am generally disappointed with the GShield portion of the build—the board’s size, position in the enclosure (blocking off the Arduino screw holes), and delicate electrical work (tiny soldering and pathetic crimp connectors) were the hardest parts of this whole project. I regret going the GShield route now.

1 Like

You are absolutely right on that. That bothers me too. Always afraid of to short it somewhere. The best idea to make another customized box for it. Maybe next step.

I pushed the pins back into their original position, booted into Windows and tried again. It’s still not working—no motor movement on any axis. Should I see more than just the one blue light on my GShield? Should there be lights on my Arduino? I see one solid one and one blinking one on the Arduino.

In that position, Turn the power switch off, try to move X Y then Z axis with your hand. Do you see any green light coming on when moving.

Yes, with the power off, I see the little LED on the GShield board next to the correct motor axis flicker when I move that axis. Works for all three axes.

I also checked the voltage output from the PSU with the power on: 24.2V at the back of the PSU and at the input to the GShield.

Good, that means Motor wires correct. Now go ahead turn it on and turn Spindle power toggle switch manually on to see if Spindle starts turning. That proofs we have 24V on it.

I don’t have spindle control set up. I am using the Dewalt 611, and was planning to manually perform spindle control until I figure out how to do it automatically.

That’s fine, I forgot. If you have Voltmeter, can you check voltage on G-Shield 24V inputs to see if there is correct power.

24V input is double green connector on the side.

I’m sorry, but I have no idea where this double-green connector on the side is. Is it in one of my photos above?

The top board have only one two wire connector. Other green connectors for Steppers. You need to check input voltage on that two wire connector.

Ah, yes, those. Yes, I checked the voltage across those two screws: 24.2V as well.