Multiple (Unwanted) Tool Passes

Good Evening,

Question… Tonight I created a vector outside of Easel of an emblem. I imported this vector into Easel and added some text to it. I was to engrave a piece of ply wood to a depth of 0.0625 (1/16") and I wanted this done in 2 passes. So I set each cut depth to .03125. Now in theory, this should cut my vector and text to my final depth in 2 passes. Next, I use the advanced feature to generate the G code and put the G code into UGS to run my machine. My problem is this. My design cut great, exactly how it was supposed to, however it did every single vector line, 4 times. It doubled the passes, making the project take twice the amount of time. I’ve scoured the settings and can’t figure out what I am doing wrong.

Any assistance?

i’d suggest zooming WAAAAAY IN on the lines/vector in easel… many times there are duplicate, concentric paths double stacked

1 Like

Or you somehow put in multiple finishing passes

How do I deleted the duplicates and keep one? When I try to remove, it removes them all…

click the “edit points” button under the shape tab, then go around the path deleting the points you don’t want

I got the same problem, and I can’t even figure out to zoom the 3d view, it looks a mile away…duh

it jockeys into position, cuts one pass, then moves off to the next spot. Why doesn’t it finish that spot? Spends all day wandering around with the tool in the air…

Hey thanks for replying, but I have no idea what that means. All I know it seems to start out ok, then it spends hours strolling around from spot to spot without finishing anything. Something that should take 20 minutes has been on for hours and none is carved completed. I mean the fuggin electric bill is gonna be astronomical…

What does Easel simulate say for time? Share the Easel project?

I’m not sharing the project because of copyright concerns, but I can tell you the time estimate was a little more than 2 hours. I left it run, and it took 13 hours. It’s doing the same thing this morning with a different project. I’m doing 2 bit cut and it estimated the rough cut at 13 minutes. It’s still cutting two hours later, and doing the same thing, strolling across the entire work surface to drop the bit for a second, then picks it back up and moves to the next location, instead of finishing that spot…

My cut depth is .026, and overall depth is .128, so it will visit each location 5 times, instead of finishing and moving along. That;s about the only way I know how to explain it.

I’ll draw something next day or two and run it, see if it does the same thing, as I suspect it will, then I will share. I just thought there was a setting I was missing…

post your $$ GRBL settings (Machine -> Advanced -> Machine Inspector). Maybe you have a bad setting in your GRBL that’s limiting motion.

$0=10 (step pulse, usec)
$1=0 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=0 (dir port invert mask:00000000)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=102.354 (x, step/mm)
$101=102.354 (y, step/mm)
$102=102.354 (z, step/mm)
$110=125.000 (x max rate, mm/min)
$111=125.000 (y max rate, mm/min)
$112=300.000 (z max rate, mm/min)
$120=5.000 (x accel, mm/sec^2)
$121=5.000 (y accel, mm/sec^2)
$122=5.000 (z accel, mm/sec^2)
$130=540.000 (x max travel, mm)
$131=540.000 (y max travel, mm)
$132=200.000 (z max travel, mm)

There’s your problem right there. You’re severely limited by GRBL for your rapid and machining speeds. I accidentally changed my $112 once thinking it was $102 and it was causing a similar slowdown.

The defaults should be (for a stock Xcarve):


Did you run through Easel machine setup at all? It doesn’t appear like you did.

I don’t remember if I did to tell the truth. I changed those values trying to get inadequate motors to function. I have since upgraded the motors, and these seem to be able to dish out all I can throw at it until the bit snaps. I’ll change those to your suggestion once this project finishes, if that ever happens, and I’ll let you know how it works out…

there’s no way this thing will survive at that setting. The brakes can’t stop the gantry accurately, motors get hot fighting inertia. That’s not the problem anyway. I ran the same project with those settings, and it did nothing for the unwanted passes. Guess I have to figure out how to edit the toolpaths, seems like the only solution… Thanks for trying anyway…

Those are just the max possible speeds. Your feed rate will still be set differently for actual cutting, that just allows the rapids to be quicker.

You complained about slow carves or better yet a mismatch between Easel and actuals. That, along with other setting choices, appear to be the culprit.

Looking at your settings again, there’s a lot of other issues (accel values low, steps/mm the same on all axis). You mentioned that you were debugging, I highly suggest rerunning Easel setup for your machine to go back to a known good configuration unless you’ve highly customized your machine. Even so, I don’t believe that most of the settings that you have are correct. Max accel of 5 mm2/sec? The stock Xcarve is 100 times greater. When settings are arbitrarily changed, it can affect the system performance and cause issues like hot stepper motors because the machine can’t perform as it is intended to perform.

Any other issue would probably be something specific to the Easel project. Multiple copies of lines or something. If you’ve got your design finalized, you can try to select everything and go to Edit -> Combine and see if it clears up.

.128 / .026 = 4.923

So yes, it will be five different cut depths and Easel will sometimes do weird toolpaths because it tries to do every cut at the same Z level. It’s all design dependent.

This is a home brew machine of my own design. I don’t even know what an x-carve is to tell the truth. Some of those settings I adjusted to help ease inadequate motors into motion without skipping. The motors have been upgraded, and I have no further problems losing home, and I will tinker more with them to get all I can out of what I’m running at a later date. This is the problem, and I don’t think any of my settings will change it. Say I want to carve the word motorcycle. The machine is set for 4 passes to reach a finished depth of .25,. The machine will start on the letter M, do one pass. Then the machine will dead head “to use a trucking term” all the way to the letter E and give it a pass. Then the machine will dead head back to the “M” and give it another pass, then all the way back to the “E” again etc. all the while it’s spent the last 5 minutes traveling, and one minute cutting, riding over everything in between with the bit in the air. Now from I can tell there are two solutions to the problem. Solution 1, change tool paths so it starts and finishes a portion before moving onto the next section, or increasing the dead head speed so it goes faster than cutting speed while traveling between cuts. I am not a rocket scientist, and the help on toolpaths is somewhat limited, and I see no mention whatsoever on increasing speed during travel, but retain the correct speed for cutting. I hope that explains it. If you would like to see the machine, go to youtube and search hoofty cnc router, and you will find it. I think there are 5 short videos there I uploaded. Frankly, I’m surprised it even works at all…
Thanks again