My Kingdom for a LIMIT switch!

Well I finally smashed my z-axis “limit” switch. I accidentally went too high on the Z and poofy-poof, no more switch. Its fine. It didn’t do anything but occupy that spot in the bracket. No idea what it was intended for but it sure as heck never “limited” anything. I imagined that it would signal the controller to “HEY BUD! THAT’S HIGH ENOUGH, STOP ALREADY!!!” but it did nothing and now it lays in about 10 pieces on my floor.

Sure would be nice if this was a true-to-life switch. I hate slamming my Z-Access just because I had my fingers on the wrong buttons (AKA Universal G-Code Sender).

Any suggestions on how to actually get a limit switch to, well, limit something??

I’m confused, how are people braking these switches? All of my switches have a screw pertruding out to prevent them from braking. Is this only a xcarve 2 thing?

Yes it’s an X2 thing.

Unfortunately these were never meant to be a limit switch. They are intended for homing only. However if you set your soft limits and home your machine then you’ll have no issues.

Should I set mine even if I have therm?

what was the code i got to put in?

When you home your machine and use soft limits grbl will check all G-code commands to see if the requested move will cause the machine to move out of bounds.

The home position is one corner of the protected cube and the values in $130, $131, and $132 define the limits to which grbl will restrict movement.

If your G-code attempts to move outside that cube, grbl will alarm and halt. This prevents (on the old system) homing switch breakage and also prevents slamming against the rails.

Everyone that homes their machine should turn soft limits on ($20=1).

Did I mention that everyone that homes their machine should turn soft limits on.

Did I mention …


So there really isn’t any way to use these switches to keep the machine from trying to Z-to-the moon. Sorta sad.

If you get homing working properly then turn on soft limits, grbl will stop your machine from honoring “Z-to-the-moon” moves.

You can install additional switches and use hard limits, but then you are stopping a machine that is already going berserk and they are sensitive to false triggering.

I have been homing my machine for almost a year and a half with no errors. Once you get it working, barring a hardware failure, it just works.

1 Like

Yes there is. I’m not sure if anyone has said this yet or not. But if you turn on and set your SOFT LIMITS. Then you home your machine at start up.


Until you get the soft limits working and such use this to help save your switches.