My project isn't centered, meshcam to easel problem!

I am importing Gcode from meshcam into easel, and I am having issues with the geometry being centered to the material.

Easel doesn’t know how big your stock is. That blue area just shows the extent of your gcode… It’s not your stock.


As much as that response makes perfect sense. It still doesn’t explain why my chose file is so off center. You can see in the following picture. The center slot is right in the middle of the stock and was carved using and svg through easel. The pocket is carved with a gcode file written on meshcam, and is supposed to be perfectly centered with the slot.

possibly check your xy position, make sure you’re not using an offset position.

Important: Using offset () will cause a view to be moved relative to its natural position , but won’t affect the position of other views or any other modifiers placed after the offset. This means you need to think carefully how you use it, not least to make sure views don’t overlap if that wasn’t your intention.

How Mach3 Can Store and Recall Table Positions Using Offsets - Bing video

If you’d like it to be perfectly centered I suggest to not use the Left front as the X,Y zero, instead use the center of the workpiece as the X,Y zero . .

1 Like

How are you setting your XY0? Are you using the same work zero as you did for the slot?

Can you share the gcode?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.