My spindle doesn't run (FoxAlien 4040-XE with 300W spindle)

HI, brand new never before user here. Trying to get my first cut on my system which is the following:
FoxAlien 4040-XE with 300W spindle.
Running Easel on an HP laptop.

I have gotten to where the computer talks to the system, and all the way to hitting the carve button and the spindle takes off and starts running the program, Only problem is the spindle is NOT turning.
I set the unit to controller, verify the spindle runs, switch back to computer, and when the program starts, no power to the spindle.
Help please, Thank You

Machine–>Advanced–>Spindle Control–>Automatic

ty it worked for me

I have the same issue. but when I go to the machine menu i don’t have advanced, I have Home, Edit, General, and Setup. I go into edit machine and under spindle control I have hardware selected and other for spindle, I also tried 24V DC spindle and neither one turns on the spindle when I get to that last step before the job runs so I can’t use my FoxAlien 4040XE directly from Easel, bummer. I have to save the gcode and use candle. any suggestions would be appreciated.

Hello Daniel, For the 4040XE you will also need to turn the knob for the RPM on the front of the controller. However “Hardware” and “Other” are the correct options on the Machine>Edit Machine page to activate the relay to output the voltage to the spindle (It was changed from “Advanced” in Nov or 2021, shortly after Neil added the info to this thread)
Please make sure the knob isn’t turned all the way down.

(BTW I happen to be one of the Admins of the FoxAlien Facebook Group)

Hi Seth,

Thanks for the reply. I did make sure the spindle knob is turned all the way up on the controller (to the right) but the spindle still does not come on when trying to use Easel. Don’t know what else to try. I wonder if I need to add some gcode command so that the spindle will run from easel. Thanks anyway.


When set to “Hardware” the Gcode line of M3 S10000 should be in the beginning of the gcode file which is the command to turn on the spindle (or rather more precisely it triggers the relay to allow the knob to function to output the voltage)

Can you grad the information from your Machine>Edit Machine Page in a photo/screen shot?
Oh, also you’d need an RPM value in the cut settings popup on the top right. (anything above about 1,000 should work, but 10,000 is what the default value is, so I typically leave it at that)

Hi Seth, everything seems to check out according to what you said to check for. I have included the screen shots of my machine and cut settings and also the gcode open in notepad. Not sure what else to check for. Thanks for trying to assist me I guess I am stuck having to save the gcode from easel and run the gcode from candle or openbuild.

Those settings are all correct, the M3 S10000 code is at the beginning of the gcode, the spindle should be coming on, possibly you’ll need to contact their customer support for more assistance. It sounds like something is physically wrong, either a faulty relay, OR other component or mis-wired, & you might need to start checking voltage with a multimeter.

I can try what you suggest but I can export the gcode from easel then run the job using a post processor like Candle that comes with the FoxAlien CNC machine and run it with no issue. Wouldn’t that mean if I did have relay or wiring issues it would not work in any other program? At this point since it does work outside of Easel I will use it that way. Thanks.

1 Like

Oh yes, youre totally right with that. If tge spindle comes on in candle but not easel, can you go to machine inpector in easel (press ctrl+shift+D to open machine inspector) and then in the console section you can send the command m3 s10000 and the spindle should come on, thats the same command that candle is sending…

I did do the “m3 s10000” command a couple times from machine inspector, and while it did report ok but the spindle still did not come on, so this was my final attempt to get it to work from Easel. I thank you for trying to help. I will still use Easel to design my CNC projects and then export the gcode and use Candle to cut the project. No big deal as that is how I have been doing it since I got the Fox Alien 4040XE but did have hope that I could use Easel for designing and post processing. Thanks again.

Daniel et al,

If you have used a laser with your FoxAlien 4040-XE, you’ll need to issue a GRBL command to turn off the laser capability ($32=0). This will turn control back to your spindle and the manual speed control knob. To switch back to a laser again in the future, issue the GRBL command ($32=1) which will disable your spindle.

Happy CNCing!


Hey Damon, That’s not a bad thought, however since Candle turns the spindle on like it’s supposed to, than the Laser Vs Spindle mode setting of $32 would not be the issue. Grbl setting are saved on the CNC and would cause the same fault in both senders if that was the cause of his issue.

However looking back though the thread, one of the things we didn’t discuss is the Easel Driver and whether that was properly installed. That is one thing that could cause Candle to work But Easel to not work :man_shrugging:

There could also be other PC related settings stopping Easel from talking to his CNC altogether, I guess we never got to the part of confirming whether Any of the cnc functions work through Easel directly. . .