My X-Carve Pro Died

Hey there all,
So while I was running a normal carve on my x-carve pro 4x4 and suddenly shortly after the carving started it just seemed to power completely off. Like the power died as if the breaker broke cuz the HMI and controller had no leds on at all, no fan, no power at all.

Things I checked:

  • breaker
  • swapped outlets
  • tried a completely different outlet (on different breaker)
  • swapped power cables
  • let sit completely unplugged for 30+min and tried to see if it started.
  • inventables is sending out a new Ethernet cable to maybe see if that was it.

The thing is, there is no power. No fans turn on the green led in the back doesn’t power on, etc.

Luckily I was filming a YouTube video too… so I caught how it happened on video… My X-Carve Pro Died. CNC Machine Gods not Happy on [vlogmas.day.09] (carving starts around 3:55)

Already reached out to inventables and like always they are on it like blue bonnet, but just curious if any of you have heard of or seen anything like this before? Any ideas?

Thanks! //g

1 Like

02:37 Bit stickout is way too much for that size shank bit. Be careful because the collet will not tighten properly without more inserted into the collet…
image

03:48 your dust shoe falls down immediately
03:58 jumpcut looks like it was raised back up somewhat. but then it continues to float up and down. I suggest tightening this at one height if you’re going to attach it to the X like that.

05:43 your thumb is touching the switch, BUT in between the switch and the AC Plug there, you’ll find a BUS Fuse, you’ve got to pull the plug out, then you can pry the fuse holder out, check that fuse isn’t blown.

Additionally I suggest verifying you have the current version grbl firmware and the correct grbl settings (specifically $1=255)

Also Check the Z axis stepper motor wiring, a loose wire can make it plunge excessively.
Check the Z axis Belt as a loose belt can cause issues with Z positioning and skipping teeth can cause a plunge like that…

1 Like

Opened up the controller? You might see if the PSU has any power at all.

2 Likes

I always check to make sure and there was part of the shank going past the top of the collet insert… but could always put more in per your included image so thanks for that.

The dust shoe does ride along the linear rail there an it hasn’t caused any problems with cut or accuracy as I’ve checked it with my calipers. However like I said in the video I am going to at some point come up with a more evolved solution

This I will definitely check… for some reason I completely missed that there is probably a fuse and maybe that is what blew.

I think it plunged like that cuz it was set to 1in movement and the keyboard registered two presses. :grimacing:

Thanks as always Seth for your great input and help.

2 Likes

I did end up opening it up and … it’s definitely powerless.

1 Like

Hey, i watched through the prior videos & saw some concerns with the F360 setup… can you send over the gcode files and the Fusion360 project file?
Cncseth@gmail(dot)com

Thanks!

The above isnt relevant to fixing the cnc machine, that fuse does handle all incoming AC so might be the issue… there might even be a spare in the plastic housing pocket so i really think it might be blown preventing any power on from occurring…

Yes I can… I will also send my new ones that I was running in the video where the xcp died.

And I’m definitely gonna check that fuse. Might go back to the shop even tonight to finish editing my vlogmas episodes should be able to check while I’m there :slight_smile:

2 Likes

Wanted to give a quick update… still waiting on inventables hardware team to decide/figure out a solution… so the machine remains dead. :frowning:

1 Like

So not the fuse? Hmmm that’s a bummer

Hey Griffin, any update from Inventables on your issue?

Unfortunately no. I was part of a pre-production testing group… sooo I don’t think I’m high priority to fix things. Luckily, I have friends with CNC machines so I’ve been able to borrow some time on theirs.

The initial thought was they were gonna ask me to pay for a new controller, new motors, and cables since those things all differ from my current pre-production machine — but I am supposed to be waiting for a price on all that, but it’s been several weeks at this point. :man_shrugging:

All of this is due to the fact my testing machine did not come with a warranty or easel pro sub like it does if you buy through their website.

Personally, I have been thinking of perhaps just getting the OpenBuilds controller and power supply and trying to retro fit the xcp with that and bring it back to life… but truth be told I am pretty new to the inner workings of the CNC machines from a hardware+computing perspective, and not sure I could make that all work. :slight_smile: Also not sure if I wanna completely exit the inventables ecosystem, but may not have a choice.

I was planning on emailing inventables again this week to remind them I’ve just been in a holding pattern, and see what they say. There is no hard feelings on my end because I did get an amazing machine for testing — just bummed it died so young — I think the motors and what not are fine it’s just the controller that is dead (which is the second one to malfunction on me). :upside_down_face:

I love all the people I’ve Interfaced with there, I just hate feeling like I’m bothering them, but I am gonna email them.

I’ll report back when I hear back //g