My Z axis doesn't stop when it touches the limit switch (Solved)

I am literally having the same issue. Just received the x carve 1000mm last week and completed setup today. I get to the z homing switch setup and it doesn’t work. I tried manually working it, went into machine inspector and nothing turns green, they all stay white. I cancelled out of the homing switch setup and attempted to set up the z probe and it does not recognize that either. Seems like there are a lot of common errors on the forums. Do you have a link of the new switched you purchased?

These are the limit switches that I purchased on Amazon.

I finally found some time tonight to go through the machine setup again to test out the new limit switches. Before I started, I went into the Machine Inspector and manually tested each switch and all registered correctly. During the Homing Sequence, the Z axis goes up, engages the limit switch, immediately stops, goes back down a tad and then begins to make a buzzing noise until I click “stop”.

I attempted this at least 4 times with no success. Any ideas?

How long does the “buzzing” happen before you stop it?
Can you post your grbl settings? Go to the console in machine inspector and send $$

At one point, I let the buzzing go for at least 20-30 seconds before I hit stop. Here is the GRBL settings from my machine. Not sure what any of this really means.


I am puzzled why the topic title says solved but that is not reflected in the latest posts?

I was hoping the “buzzing” was just the stepper moving back up really slowly. It wouldn’t take that long even at a rate of 25mm/min (your $24 setting).
Try changing $27 to 5. Just type $27=5
That will make sure you clear the switch when it does the second tap.

Different guy. The original poster never explained what resolved his problem.

@NeilFerreri1 - that seemed to do the trick!! Thank you so much for all your help!!

1 Like

Thank you so much everyone. I had the x wires and the z wires mixed up so once i switched those 2, the x-carve performed perfectly!

After buying a multimeter (Which I should have anyway) and buying new homing switches, I learnt that there was nothing wrong with the switch. Ended up dismantling the x-controller and re-assembling it. Everything was put back the same way so I’m certain something was loose somewhere.

If you run across this issue, try and reassemble the x-controller in addition to the suggested diagnostics. ¯_(ツ)_/¯