My Z axis doesn't stop when it touches the limit switch (Solved)

Hello everyone. I have finished building my X-carve and am know getting it set up to my computer. I am testing out the homing switches but can’t get past the first one, the Z axis. It is hitting the switch but then does not want to stop. It wants to continue like it’s not hitting anything so I have to stop the tests because I’m afraid that it’s going to burn out the motor. How do I fix this?

I had the exact same experience and after several attempts gave up with the assumption that the limit switch is bad. My next step (this coming weekend) will be to swap it out with one of the other switches to see if that resolves it.
If that doesn’t work I’ll have to contact customer support.

You can in Easel Machine Inspector have the status of the limit switches displayed. Do they turn green when you push the switches manually? Check connection with a multimeter also if you can.

I suspect you have the mechanical stop peventing activation of the switch. It has to go slightly further after contact to trip the switch.

1 Like

@MarkA.Bachman - So what I think you’re saying is that it could possibly be the bolt that mechanically stops the Z axis from going to far?

If so, do you think it would work if I lower the Z axis nearly all the way down, run the homing switch test and manually trigger the switch to see if that stops it? If that works, then the position of the bolt would just need to be reduced then, right?

Yes exactly.

Open Easel Machine Inspector (press CTRL+SHIFT+D or CMD+SHIFT+D on a Mac)
Press each switch by hand to see if the button status turn green when pressed.

If they all do, but machine fail to trip them, they are physically obstructed.

Well, I tried what @HaldorLonningdal suggested and none of the sensors get triggered. I double checked the wires to ensure everything is wired correctly. I can’t imagine that all 3 are bad.

Next steps?

Sounds like a wiring issue. Can you get a pic of the connection?
In the machine Inspector, were the circles all white?

Okay, do you have a multimeter on hand?
Either check for continuity or resistance on the switch itself (all three) to verify they trigger. If yes, test again for the same at the wire ends entering the Xcontroller.

It might be worthwhile to check that all boards/plugs inside the Xcontroller is firmly in place, there have been some reports of contacts seemingly okay but not entirely latched in.

@NeilFerreri1 - I will get pics of the connections tonight. As for the Machine Inspector; yes, all of the circles were white. Inventables has already had to replace the Z-axis wire so I hope that its not ANOTHER bad wire.

@HaldorLonningdal - Unfortunately I do not have a multi-meter. I will however, open up the X-Controller to ensure that everything is firmly in place.

You’re gonna want one.
This one is good for the $$

@NeilFerreri1 - thanks for the suggestion. I just ordered one! Now just need to figure out how to use it.

The simplest thing to do is turn the control knob to the bottom right speaker icon. Touch the red and black leads together. It should beep. That tells you the circuit is complete. This is a test function.

Next touch the two leads to where the wires are connected to the switches and actuate the switch. If it beeps the switch is good.

Do this for all the switches.

If they all indicate good then touch one lead on one of the switch wires and the other one to the cooresponding color wire for the limit switch on the controller end. If it beeps bthat wire is good. If not something is bad. Do this for all the limit switch wires.

You could also touch the leads to both colors for each switch at the controller end and actuate the switch if it beeps you are good. If not there is a wire problem.

1 Like

Thanks @DavidQuick for the lesson. I’ll let you know how it goes once I get in the next few days.

I left out that you have yo actuate the switch when testing. I posted the edit.

Make sure you’re wiring to the correct two switch contacts. I mis-wired once when replacing a z axis switch and the next time I homed, z didn’t stop and took out the switch. I have an older x carve that doesn’t have a mechanical stop ahead of the switch.

Turns out that all 3 of the limit switches were not working. I replaced them all with new ones I purchased on Amazon. Thanks for the help!

Good - you fixed it :slight_smile:
All 3 switches bad??

Yep. One of them just fell apart when I removed it and the other two wouldn’t register with the multi meter.