Need Help w/ new Controller & Drives [solved]

I’m finally getting around to upgrading my Controller and Motor Drives. I’ve purchased a Planet CNC MK 3/4 Controller and 4 Leadshine DM442 Motor Drives.

After recabling the machine and getting everything hooked back up I’m not able to get chooching again. I’ve already quadruple checked the wiring, and tried common anode and common cathode between the controller and drives but I can not get the motors to power up. I’ve had this machine for 18 months now so I’m not a complete novice in its operation but I’ve run out of ideas and was wondering if any here has the same setup that walk me through what I’m missing. Here is the setup as I have it now-

I think I see the problem. It’s too clean and organized. Make a rats nest out of the wiring. Something at least. You’re making the rest of us look like slobs! :smile:

[my first reaction: OOOohhh! So shiny!!]

Well, the first thing I notice is you have 1 ground wire for 26amps of power (3x orange vs. 1 blue off your PS).

Is that a loose wire in the bottom right (off the relays)?

Personally, I would have used a small bit of heat shrink after soldering to the DIN connectors, but it looks like you did a great job with it (and all around).

Does one of the stepper y-axis controllers have to be reversed like it does on the x-carve, or is it reversed at the motor?

On the relay board, what is the difference between “power” and where you have it connected to?
The closest I can find currently on their website is and it is labeled “0-10v” and “Power”

I thought about changing out a larger guage for the negative side, the second y motor drive is reversed in the software, the cube relays are for future use and not connected right now, the relay board connected to the controller is for a spindle that I have but not connected right now. I have been trying to find a way to test the drives without the controller and not coming up with anything good.

With the drives disconnected from the controller upon power up the drives are putting out 3vdc on one coil to lock them. I tried to: connect ground from the controller, then to tap +5vdc from the controller to pul+ on the drive to see if a test motor moves. So far only one drive will move the motor when using this technique.

IMO larger gauge is good, but that is not causing you your problems.

I’m not familiar with your hardware, so I don’t know how to trouble shoot it. Can you use something like Putty to connect as a serial console to the controller and manually enter commands (like you can with a g-shield)?

from what I can understand the hardware has code that prevents use unless it is licensed.
from their web site: Software is free to use with controllers that have valid license. also: Controller requires license. Without license it is limited to 25 moves. as I do not have the hardware (for the proprietary code reasons) I can not say If there is a workaround for that limitations. This is exactly why I never went to this system in the first place as I never like to be constricted to one system and one company. If this company stops doing business can you still have functioning hardware? can you add more equipment as needed? that is why I went with open sourced hardware and software.

Not too familiar with the Leadshine drivers but in theory couldn’t you wire these through a proto screw-shield to an Arduino like @PhilJohnson (and shortly myself) did with the TB6600 drivers? This would remove the dependency on licensing information.

Are the motors energizing? That is are the getting holding current when you power up?
I see green lights so it looks like you are getting power, just not signal?

Also triple check the dip switches on your leadshine drivers. The switch positions are confusing so you think the switch is set to “on” when it is actual “off” :confused:

What software are you using to drive it?

Well Leadshine wasn’t much help, I’ve got to buy a special rs-232 cable that has a RJ-11 connection on one end (haven’t seen one of those for 20+ years). Then I can try to use their software to talk to the driver. The Rep kept saying it was probably fake b/c I bought it on EBay. I cracked one of these open and if it is fake someone spent ALOT of effort on a fake, beautifully laid out and well executed.

I’m gonna try Planet CNC and see what I’m missing. I know when I power up in common cathode mode the motors don’t enable, i.e. No voltage on the motors. When I try common anode mode I get 1vdc on the “a” side. When I disconnect the controller from the drives I get 3vdc on the “a” side and nothing on the “b” side.

I’ve been able to get it to move, I think it was an issue with the software license. I reloaded the Planet-CNC license and now it will jog. Still need to figure out the setup, it’s a lot different from what I’m used to.

Getting it to move is a plus in my book. That’s most of the battle, that and tuning. On a side note I laughed at the cable thing. Not sure why we still use them. I use this little guy frequently at my job to program network switches.