Need help with UGS connecting to XCarve

So I am new to the XCarve and new to universal g code sender. I am a journeyman machinist so I am familiar with G-code. I need help in how to get UGS connected to my XCarve - when I try to jog the axis, it sounds like it tries to move but that the axis is locked or clamped or something, so something is not right here. Also does UGS need to work in conjunction with other software to work - I really just need something I can load G-code into and send to the X controller. What am I missing, I am not a computer whiz but I can follow instructions- please help

UGCS sender needs JAVA to work.

Can you give more info?

When you try to run UGCS, what things have you tried.

grbl uses 115200 for the baud rate. Do you have 115200 set in UGCS?

Did you run machine setup in Easel (setup is easiest way but it can be done another way)?

Are you sending an $X command before attempting to jog? My machine always comes up in “alarm” state when I use UGS, and I have to send $X to unlock it.

You can also import your Gcode into Easel, if you want to give that a shot. I’m more a fan of UGS, though.

Sounds like UGS is communicating alright, but motors are stalling for some reason.
Those reasons may be:

  • Microstep level incorrect vs step/mm which can result RPM above the motor capability (torque drop at speed and eventually any stepper will stall)
  • Rapid rate in excess of what the machine can do. Check $110-112 values
  • Acceleration rate may be too aggressive, or a combination with rapids that just dont play nice
  • Mechanical issues

What are your values for:
$100-102
$110-112
$120-122

A pic of the controller board exposing switches will also tell us a whole lot (if there are discrepancies)

Yes I have java, the baudrate is 115200 and I did run setup in Easel

Most likely you have a set up error with homing enabled, but you don’t home your machine.

Please post your $$ output from grbl.

Sometimes the values get corrupted. especially if you do a firmware update.

I do have the homing switches, do I need to home the machine out separately in UGS?
How do I get $$ output?

Yes. Each time you start a program that connects to your machine you need to home the machine.

Only one program at a time can connect to the machine.

From Easel you would use Machine Inspector -> advanced,

From UGCS you would enter the $$ command to grbl on the command tab.

When homing is enabled ($22=1) each time the controller powered up it does so in an alarm state. With UGS click $X to clear it.

Another thing, UGS and Easel dont like sharing com.port so make sure one of them isnt running when you try the other.

No. Home the machine to clear it, or turn homing off if you don’t want to home your machine.

By turning homing on you have told grbl that you want to use homing. grbl then comes up in the alarmed state because you haven’t homed your machine yet.

Well, mine does. Easel give you two options, Home to clear or Unlock without homing.

UGS the same, $X to clear (without homing) followed by $H to home.

See previous post edit

Not followed by, it gives you the choices for a response. Maybe the hint is ambiguous. It’s $X or $H

$X should only be used for debugging a problem. If you don’t want the alarm, turn homing off.

It havent occured to me to test, but are you saying that if $22=0 you can still use $H?

$22=1 is a prerequisite for soft limits but I have assumed it also applied to homing aswell.

Not sure this is accurate… From https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration#22---homing-cycle-boolean

That says to me that having to unlock ($X) when homing is enabled ($22=1) if you want to move the spindle without performing a homing cycle is intended behavior.

Yes, but this behavior should be avoided as it removes a lot of what grbl can do for you.

Better way to do this is just set $22=0 (no homing cycle)

Lots of people do it. ($X)

I don’t recommend it.

Personal choice.

Yes, this is what I wanted to convey to the OP with my original post.
I wasnt aware that $H could be used in an alarmed state, I was under the impression the alarm needed to be cleared first with $X

My workflow with UGS is Power ON->USB link enabled->$X->$H->set work zero->carve
Its been solid.
Apparently I can skip the $X part, will try next time.

OP seem to have a mechanical issue, not a connection issue.

Yes.