New Installation, No LED Light on HMI

I just put together my Pro, turned the power on the controller and I have a green LED. Looking at the HMI and there is no LED light on. I made sure my disconnect not engaged and still no LED. Does anybody have any suggestions while I wait for support on Monday?

Hate to state the obvious, but double check all your connections. Maybe unplug and re-plug them all in.

Are you hearing the fans on the main control unit when you flip the power switch at the back of the unit? Mine comes on immediately when it’s on.

The only cable that does anything on the HMI is the ethernet-style (8-pin) cable. The USB is just a pass-through, if that help any.

Phil thnx for the reply. Yes I have check all the cables multiple times. I have a USB cable from the back of the controller straight into my computer. Checked the ER button several time to make sure it is not engaged (pulled out). Nothing Works.

Sounds like you know what you are doing. Sucks you are having trouble.

By this, do you mean you aren’t even hearing the fans on the control unit? You might try opening up the main control unit and look for any obvious loose cables. Maybe it’s something as simple as the power cable not being connected (quick edit: not connected internally).

DavidKSantistevan has some images here of what the insides look like, maybe that can help (it looks pretty messy, though).

the fans are not comin on. when I turn on the controller is makes a clicking sound. when I unplug the ethernet cable from the HMI it makes a clicking sound. I’m wondering if there is q problem with the HMI or the ER Stop button is still in the engaged position. IDK. I’m checking that out now.

My Pro recently popped one of the glass fuses that is located in a tiny “drawer” right above where the C14 power cord plugs in the back of the controller box. You could pull those out and check the fuses for continuity. Mine both appeared opaque and were identical in appearance, but one was blown and one was not.

Just an idea.

This happened to me as well. The fix was as simple as making sure the red “emergency stop” is turned all the way in the clockwise direction until it clicks and resets. It worked for me.

Kevin & Joe

 Thnx for the reply, I did both of those, found out that the issue was a bad controller. Got it fixed and its working now.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.