Newbie Question? An erroneous tool path was generated below the wasteboard

What does this mean?

An erroneous tool path was generated below the wasteboard.

An error report has been sent to Inventables for investigation. You may try making small adjustments to the positioning or size of your design. If this issue persists, please contact the Inventables Customer Success team at 1-312-775-7009 or

I don’t think I’ve seen that before. Can you share the project?
Looks like Inventables has a check for a really bad toolpath.

It’s just cutting out circles.

I’m thinking it means I had my cut set to deep, on the first pic (black out pic) but not for sure.

I changed it now and the color changed.

I have not tried to cut it out yet since I made the changes.

You can’t set the cut to be deeper than your material is thick, so that shouldn’t have happened.
Do you still get the error? If so, please share your circle project. It will help them solve the issue.

I will check on it tomorrow.

Thank you.

I respectfully beg to differ slightly, but only in the process where you create an object at a specific depth and then change the material’s dimensional depth.

Simulating the carving process resulted in the same error the OP posted…

Interestingly enough though, the simulation still completes. Check out those waste-board-chewing toolpaths…!

There was a popup that would come up when changing the depth of the project to something less than the maximum carving depth, but that appears to have gone MIA. With the popup in place, I think it used to revert the material dimension change automatically or even change the object depths in question, but I might be misremembering those two things. I swear I remember both at various times though.

It looks to me like they have made some changes to how this issue is dealt with.


Brandon Parker

1 Like

Well, that’s weird. I wonder why they’d change that.

@BrandonR_Parker Does the error message the OP mentioned pop up every time in that case?

Ahhh…see; I knew I saw a different popup. Unless Inventables just resolved the issue, there are irregularities occurring even between simple changes with this.

I just repeated the process and the popup below was activated.

The interesting thing there is although the material thickness does not actually change, the input value remains at what I attempted to specify. This, from a computer science background, should not be allowed to occur since it leaves ambiguity.

Further testing shows that it allows the change only the first time after I add an object and then make the material depth shallower than the object. If I make the material depth back to the original depth (same as the object or deeper) and then try to make the depth shallower again, I get the popup shown above as respected. So, it seems Inventables has some irregularity with their rules being checked at various times.


Brandon Parker