No power at Xcontroller

I was wondering if anyone had issues with power on the Xcontroller? I set up my new 1000 xcarve. My router is 110v, so I switched the switch on the controller to 110v. In the final step of setting up, I downloaded Easel and was prompted to turn the xcontroller on, I plugged it in without thinking and without realising it was set to 110v and the socket I just connected to was 240v. There doesn’t seem to be any sign of life to it. I’ve tried flipping switch to 230v, I’ve made sure the Eswitch is not depressed. I’ve checked along the wires and ribbons with a tester pen and there’s power running through them all but the on light is out. Does anyone know if sending 230v to a 110v circuit would kill the box?

I’m in the UK (Scotland)

Hi there Bob, I decided to build it up in the house over the weekend. My house is 240v. My garage tools all work off 110v so I purchased the 110v router. When I was connecting it to laptop I was prompted to turn power on and as I wasn’t powering up the 110v router, before I could think about what I was doing I plugged the power in. I Realised as soon as I’d done it that if I wanted to turn power on in house to test it, I should have set it to 240v. Seems a really stupid thing to have done, had been at it all day and think I was just in a hurry to do the final part that I jumped in before thinking. I’m just wondering if I have to buy a new controller now​:grimacing::cry:

Not so sure if you need a new controller (Arduino/gshiel) or just a new power supply, probably the latter I think.

Not really sure how I’d go about diagnosing where the damage is. I know there’s still power traveling along the cables and ribbons, but none of the diodes are lighting up. If the circuits were all damaged would the power still manage to move around the board and cables?

Your AC voltage went to the DC power supply first. They use a DC power supply that outputs 24V DC to the circuits. Most likely, the power supply would be damaged and not the electronics themselves. If you’re not seeing the LED but you are seeing power on the cables, you may not have the ribbon cable fully seated from the main board to the front breakout board. I’d check the cable to ensure its fully seated (mine was incredibly stiff to get seated fully.

If you’ve got a volt meter, you can plug up just the power supply and measure the V+ output to ensure you have 24VDC coming out. You can also check at the end of the black/red wire that goes from the power supply PCB to the control PCB (and out to the Estop button). That should also be reading 24VDC.

Pin 7 of the cable going to the front should read 5V (pin 9 is ground) which would be the voltage that is powering the green LED on the front.

Does your PC recognize the device when you plug it in and turn it on? The Xcontroller has an onboard 5VDC power supply based on the schematic that is used for the USB chip and the Arduino so if your PC can see the device, the damage may be minimal if any at all.

1 Like

forehead slap! Must remember, coffee THEN computer…

2 Likes

Thanks for taking the time to reply, really appreciated👍 I haven’t got a volt meter, will pick one up. In the meantime I’ll double check that the ribbons are fully seated. The power switch at the moment is set to 230v (house mains power). For testing purposes would it make any difference if I switched it back to 110v and ran power from my garage which is 110v?

Yeah, I stripped it back a few times last nite to change the V to the correct one for house, then again to double check connections and again lol to check there was power running through cables and I also tried bypassing the e switch in case there was any issue with it. Yesterday afternoon I was looking at the power cord and plug and panicked as I thought I’ve bought a 110v router and the machine must be 230v. I looked it up online and it stated it was both but by default was set to 110v. Then just as I was finished building the machine, the last message warned that the router shouldn’t be connected directly to the X controller as that doesn’t power it, so I thought as the router won’t be powered up I could work the controller off the 230v for installing Easel. I basically plugged the box in before the penny dropped that I hadn’t flipped the switch back. Hopefully I can get it sorted as up to the point I plugged it in everything was coming together easier than I thought. Thanks again for the suggestions👍

Xcontroller comes pre-set for NEMA23 motors. No adjustment needed for the Xcontroller.

1 Like

Can you precisely dial it in to the mA level? No of course not. But Inventables themselves have confirmed they are set from the factory for NEMA23 motors (only option on new machines). When I got mine, I verified they were set properly and they didn’t need modification for NEMA23.

The Xcontroller board has a silk screen on it showing pot position versus current (from the Inventables instructions and I had the same thing on my board). It’s a good guide but not 100% precise. But the instructions themselves also say, unless you’re an advanced user, you don’t need to change anything on the board (http://x-carve-instructions.inventables.com/1000mm/step8/).

http://x-carve-instructions.inventables.com/1000mm/step8/

  1. Prepare Controller Board

First sentence: “Unless you’re an advanced user looking to make some tweaks or want to use your X-Controller without re-wiring your machine, you won’t need to make any adjustments.”

1 Like

The Xcontroller is a pretty good improvement over the Gshield. I used the Gshield first and then got my Xcontroller and Inventables really made it as close to plug and play as you can expect for a DIY kit.

Tried all the connections and they’re fine. Went and bought a voltage meter and I’m not getting anything out of the power supply. The pen tester that lights up and beeps was picking up something along the cables and ribbons sometimes when I passed over them, then tried again and nothing. Not sure why that happened. Tried connecting it up to laptop but it didn’t recognise it. Looks like a new power supply at least is needed​:thinking::worried:

Maybe it has an internal fuse? Just a guess. Can it be opened for inspection?

I’ve not noticed a fuse inside the box. I’ve been contacted from inventables and they recon I’ve fried the PSU. They’ve kindly offered a replacement at no charge, which is more than I deserve after making such a stupid error. Hopefully that will sort the problem, fingers crossed😁

2 Likes