Not again..... connection issues

So i am finally done building the new x-carve. did some simple mod to it making it so i can use the x-controller on the right side of the machine, no big deal. plug it in and my computer doesn’t show arduino in the comm port or system devices under the device manager. i did the support thing and loaded an older version of arduino, nothing. i THINK i reflashd it right (some of the instructions confused my simple mind), still nothing. this was the issue i had with my last machine before returning it and upgrading everything to the x-controller and whatnot. i have windows 7 home edition, by the way


It could be a common problem with the X-controller.

1 Like

New cable, same issue. Not being recognized by the computer

well that’s a new one…
i was moving the machine around by hand to get pictures of the modifications i did, the computer recognized the x-controller, but only as i was moving it, generating a little power through the movement of the stepper motor

Inventables sent me a new power supply this week.
Got it installed yesterday and I still have the same issues.

No I did not do that.
I’m goin to try that today.

Forgive my stupidity, but how do I do that? It’s one of the new ones, by the way. It was from the last batch they got in after the holidays.

Versus the large USB connection?

Well that’s not happening today.
I just opened it up and its a different connection.

I know.
Its my own damn fault for not trying it.
I will have to order a cable.
Is it something that worked for you?
Would you by chance have a cable part number?

Well come to find out my wife has a USB cable that will fit.
So I did the bypass of the bulkhead connector.
I still have the same problems.
I do however have Inventables working on the problem also.

1 Like

I’ll try mine as well, probably tomorrow when I’m a little more sober

1 Like

found a plug that worked. machine was recognized right away. so what does that mean for my machine?
di a test run, it works, but i’ll need to tinker with the settings. it would do one pass to the depth i wanted, then dig in like it was its last meal. but that’s for another thread.

I must say that Inventables is very responsive to their customers needs.
They are now having me load some new software to help get to the root cause of the problem.
I will be sending them the reports that it spits out.
I really hope this works.


New cable received, machine was recognized. Did some test cuts and all is well, just need to work on placement and the z-probe stuff. Thanks for the help everyone. And thanks Inventables customer support for being so fast and understanding with the issues. The X-Carve community and the Inventables customer support are the reasons I didn’t give up on the machine.

Thanks again!

Glad to hear that you got it going.
I’m hoping for success myself this afternoon.

1 Like