Not aligned with the homing switch

New problem here. Now when I home ($h) the bit is no longer right above the fysical switch. I can see when I starts to carve and it goes down to hit the height-switch it will hit the smartclamp instead. what now?

settings from machine inspector:
$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=0 (dir port invert mask:00000000)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=1500.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=12000. (rpm max)
$31=0. (rpm min)
$100=88.889 (x, step/mm)
$101=88.889 (y, step/mm)
$102=377.893 (z, step/mm)
$110=5000.000 (x max rate, mm/min)
$111=5000.000 (y max rate, mm/min)
$112=800.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=60.000 (z accel, mm/sec^2)
$130=300.000 (x max travel, mm)
$131=203.200 (y max travel, mm)
$132=80.000 (z max travel, mm)

I tried to restore settings to default:

$RST=$

But that didn’t help either. anyone with some help here?


sorry for the bad picture. right from the webcamera with some dust on the plexiglass in front of the camera.

in the picture you see it’s just little off…

I think I might have the same issue… Not as big though, but it seems that my bit doesnt hit the smartclamp swith in the center. It seems like the button tilts when its pressed so it doesnt find the correct homing depth, and carves into the wasteboard when set to cut through material.

Thanks for letting me know that more have this issue. have it been like this from you got the machine? mine did hit the center of the button until yesterday.

I did find even more problems right now. it seems one of the ballbearings have gotten loose and i didn’t understand it before now. not sure when that happened:

Not sure if this is connected to the first problem. anyone have a clue on fixing this?
cant find anything on that:
http://carvey-instructions.inventables.com/

The top ball bearings are loose on both sides. I could push theme in on top on both sides. looks like thightning that would be difficult. not sure if it is a problem or not. anyways pushing the ballbearings back didn’t fix my initial problem on reaching the button with the drill-bit.

@ThomasBroen
could you post how it looks under machine inspector(machine->advanced-machine inspector) in easel on your machine after you have homed?

I have to say that it is not consistent at my carvey… I tried carving again today, and this time it was better. Maybe I’ve had dust or debris on my homing switches. I will see how the code looks next time I run the machine…

Luckily I haven’t had the kind of issues that you have with your ball bearings. But I am starting to wonder if there are some parts that I should start checking more often for tightening etc.

I am having exact the same issue. Not sure if this is a driver issue. It seems it happened when updating the driver on my Mac. At least I did not recognize this issue before. Now my carving bit does no linger reach the home switch and just comes down a tiny little bit next to it. So the software never homes.
Have not found a way to overcome this issue. Will check on the bearings tonight and see if they are loose.
I am wondering if someone knows a way to manually calibrate the easel software and manually set the home position?

1 Like

I have been in contact with support regarding this. Apparently there is no immediate solution for the issue. I have been trying to overcome the error by using extra spacing paper etc to “Cheat” the smart clamp. Maybe you can find a way to cheat on the homing. Maybe glueing a thin plate to the smart clamp switch so it gets a little bit bigger… Not ideal, but at least it may let you carve.

Well I did overcome the issue last time i tested.
I had to send a x-move using the machine inspector in easel.

First I found the sweet spot on the x-axe using this command(x17 seems to be right in the center of the button in my case):
G0 X17

Then I saved it as a parking spot:
G28.1

Issued a home:
$H

Then tested that my new parkingspot is in center of the button:
G28

and G28 moved it right in the center of the button. when I pushed carve now, it first seems to home and then go right to the parkingspot I saved, then it goes down on the z-axe and hits the detect button perfectly in my case.

Not sure if G28 is saved to memory, perhaps one have to set the G28-parkingspot after every power on.

My ballbearing problem is handled with inventables support.

1 Like

i have same issue~