Not Carving entire path even though it shows in preview

Hi there all!
Curious if anyone can lend a hand as to why when I create an object to carve in Easel Pro, while the preview shows all of the objects, it doesn’t actually carve the entire path? Images are easier, please see attached and look very closely at the carving path.

The preview shows the blue path doing most of the tree, but skips the trunk/one top portion. I don’t understand what the issue is!

Any help would really be appreciated. I’ve tried changing how it carves (inside, outside etc), the depth, the bit etc, nothing helps other than removing the words etc.

If you look close the actual tool path is not in those areas, the graphics are smaller than your bit.

1 Like

I totally agree. What I’d like to know is how/why? The thickness in that area should be the exact same as every other part of the tree. As soon as I remove the white box from behind the text, it previews as it should and the path goes into those areas. It doesn’t make any sense…

The actual cut in the wood was because I didn’t notice the path missing from those areas until after I had run the job.

I’d rather not change the design (and in my head, I shouldn’t have to!) so if you’ve got any other suggestions I’d love to hear them :slight_smile:

Can you share the design so that we can take a look at it and assist if possible?

  1. Go to the menu option below:
  2. Select the Unlisted radio button
  3. Copy the link
  4. Press the Close button
  5. Paste the link into a post here.

Also, after simulating the toolpaths, click on the verticle ellipsis in the preview pain. If there is an “Uncut Area” checkbox available, select that and the areas where the bit cannot travel due to size constraints will show up in red.



Brandon Parker

Instead of leaving a white box, select the white box and the tree and right click and select combine, this will edit the tree and remove the white box.
This may resolve the conflict

Hey Brandon,
Here’s the link to the project. No uncut areas show up when I simulate.
Have a look and lmk if you can figure it out!

Hey Seth,
Tried that. It just combines the tree into a closed shape. Funny part is, it’ll carve the entire path after I do that. :triumph:
Have a look.

Its your box you are using to knockout the tree, Delete it and replace it with a square from the dropdown set to zero. Should fix it


tested it, that will fix it

I can not get that to work either. The toolpath for that short section of the tree on the left side is not being generated, but it should be.

I did get a better result by sending the font through the Xploder app. Moving the new vector object around even a little results in similar issues.

Even when I recreate the design in a new project I get similar results where the V-Bit should be traveling, but the toolpath is just coming up short.

I would create a new project with just the one item that is causing issues and send it to Inventables to have them look at it. This is definitely some type of toolpath generation bug that has gotten introduced. I can replicate the problem by just covering the tree partially with a zero-depth square. The toolpath should definitely be generated up to the edge of where the box overlaps the tree and it is not. And, it appears to be only occurring on contour paths with V-Bits.

I’m going to mock up a simple design and send it in.


Brandon Parker

I sent in the error report with a file and images showing what is going on.

Here is the same Easel project and image I sent where I just used a standard tree from the library and a zero-depth rectangle.


Brandon Parker

Well I’m glad its not just me! :upside_down_face:
I even tried creating a simple tree in Illustrator and importing the SVG and I had the same issue. So it’s not just the tree element within Easel.

Guess I’ll have to find a work around for the time being. Thanks so much for looking into this. If someone comes up with a fix please lmk! :+1:

It’s a pretty shallow carve. Are the text and tree set to the same depth?

Try to duplicate the tree, flip horizontally. line them up by using the position tab then combine them. I just ran it and it was carved correctly.

Technically when using a V-Bit, you should be able to get super-thin lines since Easel/GRBL can just barely scratch the surface with the point of the bit (depending on the v-bit of course; some have flat spots and some are true point). Easel is showing that the line should be cut and not producing “Uncut areas” for the design, yet it refuses to produce tool paths for the tree in the areas next to something else.

In my super-simple example with just the tree and a zero-depth rectangle, I just did exactly what @WillieFields mentioned, but the results are the same. Easel refuses to create tool paths (at least they are not being generated in the preview) for the same areas.


I have some carving to do tonight or tomorrow and will see how it carves vs. the toolpaths being displayed. Either way it is a bug since not displaying tool paths for areas that will be getting toolpaths generated for carving when the GCode is generated is actually a way worse bug than just not generating the tool paths at all.


Brandon Parker

is this what you are trying to do, been away from my show for a few days

Sort of, but you’ve created a boundary vs a line. So when you select anything other than “clear a pocket” it won’t give the desired results. I found a work around where I just created those 2 chunks of the tree that wouldn’t carve and put them over top of the existing tree. It carved no problem with the faked work around. Thanks for all the input! I really appreciate the quick replies - it saved me from thinking I was doing something wrong!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.