Now here's a real puzzle! (Not returning to work zero after carve)

I have an X-Carve 1000 with an X-Controller, a VFD spindle and a vacuum dust extractor.
I have a engraving job that takes about 5 minutes to complete and when I run this job above the material (cutting air) with vacuum and spindle running, all completes and the cutter returns to zero at the end.
If I run the same job and cut into the material, the job completes but doesn’t return to zero - with or without the vacuum running so I think that eliminates static from dust.
The X-Controller is at Grbl 1.1g
I’ve used two different PCs both with both Candle 1.1.7 and UGS (Windows 10 fully updated and USB sleep turned off)
I’ve used MDF and blockboard stock.
Homing switches and VFD power to the spindle are screened and earthed.
USB cable has a built in noise suppressor.

I’m at a loss to what to look at next to fix this.
Ideas more than welcome.

Do the carve come out good?

If not, is only along the X-axis or Y-axis you detect offset?

The carve comes out just fine.
I’m doing a two part carve. The first part engraves the letters and the second part cuts the contour for the plaque with a tool change between the two.
The first job of engraving cuts just fine except that instead of rising above the work and then returning to zero at the end of the job (ready for the tool change), it just rises above the work and stops. Ah, I thought - never mind, I’ll click return to zero and carry on regardless. This actually worked and I was able to change the tool and start the second job. It started well but then stopped partway through. I then clicked return to zero again and restarted the second job but again it stopped (in a different place this time). I tried this a few times and it eventually got itself in a real tangle and wouldn’t respond to very much at all. It didn’t do anything particularly nasty but just didn’t respond very well to commands.
The only way out of this was to restart everything and start again - and of course throw the wood away again.
The lesson here appears to be that if it hasn’t returned to zero the chances are that it’s not going to succeed after that.

Okay, it sounds like your USB-connection is dropping out - most likely due to RF-noise.
When it does, and reconnect, the syncronisation between machine and work coordinates is lost.

Do you have homing switches installed?
As long as the machine and work coordinates are in sync there is no need to return to zero before starting 2nd stage, only a re-zero of Z may be required.

Work zero is stored as an offset to machine zero. With homing switches you can have a consistent machine zero (and consistent work zero)
Returning to zero does not affect this.

Yes, I have homing switches installed and I set machine zero when I switch on. I only want to return to zero so that I can reach the spindle to change the bit.
I can see your point though, that when the machine is cutting into wood rather than air, the RF noise will increase. I have one of the better range of USB cables with a noise suppressor on it so I would have thought that would avoid the problem. If it is RF noise being picked up by the USB cable I wonder how I can prevent/shield it?

I had RF-noise issues too, it wasnt until I started using an externally powered USB-hub it went away.

A VFD is very noise (RF-wise) so take care that signal and power wires dont run parallell or close to eachother, if possible.

I think I may have made some significant progress this afternoon!
Taking Haldor’s comments I went back to the machine and made some changes with RF noise in mind. I moved the laptop away from the VFD drive and the X-Controller away from the VFD drive too. I also replaced the USB cable. However, the problem remained :frowning:
However, while puzzling over the problem I had a random thought. I have been using a 4 way adapter to power the VFD, X-Controller, dust extractor and laptop. It’s this that I think has been causing all the problems :crossed_fingers:
I have now plugged each device into a separate wall socket rather than all through a single power point via a multi plug array and in this configuration I have successfully run one job without a hitch. OK, it’s only one job but that’s one more than I’ve managed before.
My theory is that the dust from the vacuum is causing static and this is draining through the electrically conductive dust pipe (as designed) to the VFD drive and then to earth through the multi way adapter. I think it’s in the multi way adapter where the electrical spike is finding its way back into the X-Controller. That’s my theory for today - I hope the theory holds when I retest tomorrow.

Retested this morning and now all OK. It would appear that it was the cheapo 4 way plug extension cable that was the cause of all my troubles.
Thanks for you help Haldor.

No problem :slight_smile:
Dealing with RF-noise can be highly frustrating…!