Odd behaviour from X-Controller?

I’ve been doing some carves the last few days and have noticed the machine pausing at various points in the carve and then continuing on… No big deal, the carve is completed flawlessly. Today however, I went to check on it and it was pausing more than what I consider “normal behaviour”. Typically, it’s been pausing for maybe up to two or three seconds, then continuing. This time I witnessed it pause for maybe five to ten seconds, then when it continued it moved the x-axis over so violently it dislodged to wood and snapped the x-axis belt, almost as if when it restarted, instead of continuing where it paused, it lost data and tried to continue at a new point a few seconds later, if that makes sense.

Anyone else seeing any of this and does anyone have an idea what might be going on???

Mine has done this a couple of times but i’m not using a x-controller.

? USB communication issue maybe ?

mine has been doing this lately and i run the stock controller but only on large files