Picsender and UGS not working

Hello all,
I am trying to connect to UGS and I keep getting “GRBL has not finished booting” this does not stop. With Picsender I am getting no response though it is saying that I am connected. Any ideas?

Usually this is a baud rate mis-match. Grbl communicates at 115200.

1 Like

Thanks look like Picsender is now working but all axis are reversed. How do I rectify this?

You can either go through machine setup in Easel or you can learn how to setup the parameters for grbl with UGCS, PicSender, or any other G-code sender that has the ability to update the grbl parameters.

I think most people use Easel to setup their machines for the first time even if they don’t plan to use Easel for their work flow.

Besides Larry, expert help with PicSender is available from Jeff at: https://www.picengrave.com/Contact.htm
Thanks,
John

He is setting up a new machine. Not a problem with PicSender, he just didn’t have the correct baud rate.

1 Like